summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-06-01 14:45:33 +0200
committertytan6522021-06-01 14:45:33 +0200
commitdeed631bc14124e1aa8ecebe4af1f72e35a6781e (patch)
tree894ea9b8a2b4a37b4a38c537d8140845dcaa446d
parent7d10d3cbcc70e14a7f9de64fb60d7d0a88389ebe (diff)
downloadaur-deed631bc14124e1aa8ecebe4af1f72e35a6781e.tar.gz
build: Update dependencies and prepare 27
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD67
2 files changed, 32 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c21d170f3d4..108ede26282d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, working VLC sources and my bind interface PR.
pkgver = 26.1.2
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -10,29 +10,29 @@ pkgbase = obs-studio-tytan652
makedepends = git
makedepends = libfdk-aac
makedepends = libxcomposite
- makedepends = x264
makedepends = swig
makedepends = luajit
makedepends = python
+ makedepends = cef-minimal-obs
depends = ffmpeg
- depends = jansson
- depends = libxinerama
- depends = libxkbcommon-x11
depends = mbedtls
- depends = qt5-svg
- depends = curl
depends = jack
depends = gtk-update-icon-cache
- depends = qt5-x11extras
+ depends = x264
+ depends = rnnoise
+ depends = libxss
+ depends = libxrandr
+ depends = nss
+ depends = at-spi2-atk
depends = vlc-luajit
depends = ftl-sdk
optdepends = libfdk-aac: FDK AAC codec support
optdepends = libxcomposite: XComposite capture support
- optdepends = libva-intel-driver: hardware encoding
- optdepends = libva-mesa-driver: hardware encoding
+ optdepends = libva-intel-driver: Hardware encoding
+ optdepends = libva-mesa-driver: Hardware encoding
optdepends = swig: Scripting
optdepends = luajit: Lua scripting
- optdepends = python: scripting support
+ optdepends = python: Python scripting
optdepends = v4l2loopback-dkms: Virtual camera output
provides = obs-studio=26.1.2
conflicts = obs-studio
@@ -49,10 +49,6 @@ pkgbase = obs-studio-tytan652
sha256sums = 109ffd8702b7b3973f4167f8821196b304df268205bf19e277281e65a0448182
sha256sums = SKIP
sha256sums = SKIP
- source_i686 = https://cef-builds.spotifycdn.com/cef_binary_76.1.13+gf19c584+chromium-76.0.3809.132_linux32_minimal.tar.bz2
- sha256sums_i686 = baa0624e2d6b86a60d18117cb65e125f882ef66cf413cd7ac63a480d904004f0
- source_x86_64 = https://cef-builds.spotifycdn.com/cef_binary_76.1.13+gf19c584+chromium-76.0.3809.132_linux64_minimal.tar.bz2
- sha256sums_x86_64 = 6b0dfa8ddafcec822fcd20018cf081959ffa6d0565be3793da1f596ac0733c38
pkgname = obs-studio-tytan652
diff --git a/PKGBUILD b/PKGBUILD
index bef5ad4b9500..948aaed19537 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
-# NOTE: If the CEF version (for the browser source) is not available in your architecture, OBS will be built without it.
-
pkgname=obs-studio-tytan652
-# Use same CEF as obs project PPA
-_cefver=76.1.13+gf19c584+chromium-76.0.3809.132
-#_cefver=87.1.14+ga29e9a3+chromium-87.0.4280.141
pkgver=26.1.2
-pkgrel=8
+pkgrel=9
pkgdesc="Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, working VLC sources and my bind interface PR."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
-depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
- "qt5-svg" "curl" "jack" "gtk-update-icon-cache"
-
- "qt5-x11extras"
+depends=("ffmpeg" "mbedtls" "jack" "gtk-update-icon-cache" "x264" "rnnoise"
+
+ # "libxinerama" "qt5-svg" provided by "vlc-luajit"
+ # "libxkbcommon-x11" provided by "qt5-base"
+ # "jansson" "curl" provided by "ftl-sdk"
+
+ # Needed by obs-browser
+ "libxss" "libxrandr" "nss" "at-spi2-atk"
# AUR Packages
"vlc-luajit" "ftl-sdk")
@@ -24,16 +23,18 @@ depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
# So I also created vlc-luajit, a VLC package compiled with the same lua as OBS.
# But to make people unable to install VLC official package with obs-studio-tytan652.
# I decided to make vlc-luajit a dependency of OBS rather than an optional one.
-makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264"
- "swig" "luajit" "python")
+makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "swig"
+ "luajit" "python" "cef-minimal-obs") #"pipewire")
optdepends=(
"libfdk-aac: FDK AAC codec support"
"libxcomposite: XComposite capture support"
- "libva-intel-driver: hardware encoding"
- "libva-mesa-driver: hardware encoding"
+ #"pipewire: PipeWire capture support"
+ #"xdg-desktop-portal-impl: PipeWire capture support"
+ "libva-intel-driver: Hardware encoding"
+ "libva-mesa-driver: Hardware encoding"
"swig: Scripting"
"luajit: Lua scripting"
- "python: scripting support"
+ "python: Python scripting"
"v4l2loopback-dkms: Virtual camera output"
)
provides=("obs-studio=$pkgver")
@@ -43,47 +44,22 @@ source=(
"python_fix.patch" # https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/3335.patch
"use_system_ftl-sdk.patch" # https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/4018.patch
"bind_iface.patch" # https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/4219.patch
+ #"en-US.ini" # Because the patch created by github can't manage different line endings
"obs-browser::git+https://github.com/obsproject/obs-browser.git"
"obs-vst::git+https://github.com/obsproject/obs-vst.git#commit=cca219fa3613dbc65de676ab7ba29e76865fa6f8"
)
-source_x86_64=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linux64_minimal.tar.bz2")
-source_i686=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linux32_minimal.tar.bz2")
-#source_aarch64=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linuxarm64_minimal.tar.bz2") will be available for OBS 27
sha256sums=(
"SKIP"
"430d7d0a7e1006c1f6309ad7d4912033dadd542b641f9d41259a5bad568379c9"
"c19c48fa8cc2821281ae452acc19c3003010224ecf2f2080991a5398bac4ec2e"
"109ffd8702b7b3973f4167f8821196b304df268205bf19e277281e65a0448182"
+ #"a43f2ad974104888ef36eef49b3e60dc26f7cfc0f48300726c861978ae5ae3ea"
+ #"b242289d5d186bee253ba82185ff43d5e93d7f89254055e9d4833350c6a1cc7a"
"SKIP"
"SKIP"
)
-sha256sums_x86_64=("6b0dfa8ddafcec822fcd20018cf081959ffa6d0565be3793da1f596ac0733c38")
-#sha256sums_x86_64=("")
-sha256sums_i686=("baa0624e2d6b86a60d18117cb65e125f882ef66cf413cd7ac63a480d904004f0")
-#sha256sums_i686=("")
-#sha256sums_aarch64=("")
-
-if [[ $CARCH == 'x86_64' ]]; then
- CEF=ON
- CEF_ARCH=64
-elif [[ $CARCH == 'i686' ]]; then
- CEF=ON
- CEF_ARCH=32
-#elif [[ $CARCH == 'aarch64' ]]; then
-# CEF=ON
-# CEF_ARCH=arm64
-else
- CEF=OFF
-fi
prepare() {
- # Build CEF wrapper
- cd "$srcdir/cef_binary_${_cefver}_linux${CEF_ARCH}_minimal"
-
- sed -i 's/-Werror/#-Werror/g' cmake/cef_variables.cmake
- cmake .
- make libcef_dll_wrapper
-
cd "$srcdir/obs-studio"
#git config submodule.plugins/obs-vst.url $srcdir/obs-vst
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
@@ -110,14 +86,13 @@ prepare() {
build() {
cd obs-studio
-
mkdir -p build; cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_BROWSER=$CEF \
- -DCEF_ROOT_DIR="$srcdir/cef_binary_${_cefver}_linux${CEF_ARCH}_minimal" \
+ -DBUILD_BROWSER=ON \
+ -DCEF_ROOT_DIR=/opt/cef-obs \
-DOBS_VERSION_OVERRIDE=$pkgver ..
make