summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-05-29 13:35:37 +0200
committertytan6522023-05-29 13:35:37 +0200
commitf65d2e7638ffff4a8b64b4f9990ad748d4f35f81 (patch)
tree9ed1e32b9c1ebb7716bde1fb3640e0ea710c0824
parent3ace43733ef36b527b248844631dbdf5c094b47e (diff)
downloadaur-f65d2e7638ffff4a8b64b4f9990ad748d4f35f81.tar.gz
build: Update to 29.1.2 plus deps fixes
-rw-r--r--.SRCINFO79
-rw-r--r--PKGBUILD108
2 files changed, 119 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b73302c26f93..160cf232e35f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,71 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes
- pkgver = 29.1.1
- pkgrel = 2
+ pkgver = 29.1.2
+ pkgrel = 1
url = https://github.com/obsproject/obs-studio
arch = x86_64
arch = aarch64
license = GPL3
+ makedepends = asio
makedepends = cmake
+ makedepends = jack
makedepends = git
+ makedepends = libajantv2
makedepends = libfdk-aac
- makedepends = swig
makedepends = luajit
- makedepends = sndio
- makedepends = python>=3.11
- makedepends = asio
makedepends = nlohmann-json
+ makedepends = python>=3.11
+ makedepends = sndio
+ makedepends = swig
+ makedepends = systemd-libs
+ makedepends = v4l-utils
makedepends = websocketpp
- makedepends = libajantv2
makedepends = cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1
- depends = jack
- depends = gtk-update-icon-cache
- depends = x264
- depends = rnnoise
+ depends = alsa-lib
+ depends = curl
+ depends = ffmpeg-obs>=6
+ depends = fontconfig
+ depends = freetype2
+ depends = ftl-sdk
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = jansson
+ depends = libglvnd
+ depends = libpipewire
+ depends = libpulse
+ depends = librist
+ depends = libva
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxkbcommon
+ depends = mbedtls>=3.4
depends = pciutils
+ depends = qt6-base
depends = qt6-svg
- depends = mbedtls>=3.4
depends = qt6-wayland
- depends = libxcomposite
- depends = pipewire
- depends = xdg-desktop-portal
- depends = libxss
+ depends = rnnoise
+ depends = speexdsp
+ depends = srt
+ depends = util-linux-libs
+ depends = vlc-luajit
+ depends = wayland
+ depends = x264
+ depends = zlib
+ depends = at-spi2-core
+ depends = dbus
+ depends = expat
+ depends = libcups
+ depends = libdrm
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
depends = libxrandr
+ depends = mesa
+ depends = nspr
depends = nss
- depends = at-spi2-core
- depends = ffmpeg-obs>=6
- depends = vlc-luajit
- depends = ftl-sdk
+ optdepends = jack: JACK support
optdepends = libfdk-aac: FDK AAC codec support
optdepends = intel-media-driver: Hardware encoding (>= Broadwell)
optdepends = libva-intel-driver: Hardware encoding (<= Haswell)
@@ -44,10 +74,11 @@ pkgbase = obs-studio-tytan652
optdepends = luajit: Lua scripting
optdepends = python>=3.11: Python scripting
optdepends = sndio: Sndio input client
- optdepends = v4l2loopback-dkms: Virtual camera output
- optdepends = libajantv2: AJA NTV 2 support
+ optdepends = v4l-utils: V4L2 support
+ optdepends = systemd-libs: V4L2 support
+ optdepends = v4l2loopback-dkms: V4L2 virtual camera output
optdepends = decklink: Blackmagic Design DeckLink support
- provides = obs-studio=29.1.1
+ provides = obs-studio=29.1.2
provides = obs-vst
provides = obs-websocket
provides = obs-browser
@@ -58,7 +89,7 @@ pkgbase = obs-studio-tytan652
conflicts = obs-linuxbrowser
conflicts = libva-vdpau-driver
options = debug
- source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.1
+ source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.2
source = obs-browser::git+https://github.com/obsproject/obs-browser.git
source = obs-websocket::git+https://github.com/obsproject/obs-websocket.git
source = qr::git+https://github.com/nayuki/QR-Code-generator.git
diff --git a/PKGBUILD b/PKGBUILD
index 5b9db7bcf35c..54433e34f83e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
pkgname=obs-studio-tytan652
-pkgver=29.1.1
-pkgrel=2
+pkgver=29.1.2
+pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -11,27 +11,42 @@ license=("GPL3")
_mbedtlsver=3.4
_pythonver=3.11
depends=(
- "jack" "gtk-update-icon-cache" "x264" "rnnoise" "pciutils" "qt6-svg"
- "mbedtls>=$_mbedtlsver"
-
- # "libxinerama" provided by "vlc-luajit"
- # "libxkbcommon-x11" provided by "qt6-base"
- # "jansson" "curl" provided by "ftl-sdk"
-
- # Needed to use Qt on Wayland platform
- "qt6-wayland"
-
- # Both needed to load linux-capture, so those two are no longer optional
- "libxcomposite" "pipewire"
-
- # Needed to use PipeWire capture
- "xdg-desktop-portal"
-
- # Needed by obs-browser
- "libxss" "libxrandr" "nss" "at-spi2-core"
-
- # AUR Packages
- "ffmpeg-obs>=6" "vlc-luajit" "ftl-sdk"
+ "alsa-lib" # Deps of ALSA plugin and CEF
+ "curl" # Deps of OBS Studio and rtmp-services plugin
+ "ffmpeg-obs>=6" # Deps of OBS Studio and FFmpeg plugin
+ "fontconfig" # Deps of Freetype2 plugin
+ "freetype2" # Deps of Freetype2 plugin
+ "ftl-sdk" # Deps of Outputs plugin
+ "gcc-libs" # Deps of any C related binary
+ "glib2" # Deps of libobs, PipeWire plugin and CEF
+ "glibc" # Deps of any C++ related binary
+ "jansson" # Deps of libobs and rtmp-services plugin
+ "libglvnd" # Deps of libobs-opengl and OBS Studio
+ "libpipewire" # Deps of the PipeWire plugin
+ "libpulse" # Deps of PulseAudio monitoring (in libobs) and PulseAudio plugin
+ "librist" # Deps of FFmpeg plugin
+ "libva" # Deps of FFmpeg plugin
+ "libx11" # Deps of libobs, libobs-opengl, X11 Capture plugin, frontend tools plugin, obs-browser and CEF
+ "libxcb" # Deps of libobs-opengl, X11 Capture plugin and CEF
+ "libxcomposite" # Deps of the X11 capture plugin
+ "libxkbcommon" # Deps of libobs, OBS Studio and CEF
+ "mbedtls>=$_mbedtlsver" # Deps of OBS Studio and Outputs plugin
+ "pciutils" # Deps of FFmpeg plugin
+ "qt6-base" # Deps of OBS Studio and any frontend plugin
+ "qt6-svg" # Deps of OBS Studio
+ "qt6-wayland" # Needed to use Qt on Wayland platform
+ "rnnoise" # Deps if the filter plugin
+ "speexdsp" # Deps if the filter plugin
+ "srt" # Deps of FFmpeg plugin
+ "util-linux-libs" # Deps of libobs
+ "vlc-luajit" # Deps of VLC Plugin ("vlc" issue crashes)
+ "wayland" # Deps of libobs, libobs-opengl and CEF
+ "x264" # Deps of the X264 plugin
+ "zlib" # Deps of libobs
+
+ # Deps of CEF
+ "at-spi2-core" "dbus" "expat" "libcups" "libdrm" "libxdamage"
+ "libxext" "libxfixes" "libxrandr" "mesa" "nspr" "nss"
)
## About vlc-luajit
# The official VLC package will make OBS crash when a VLC source is used.
@@ -42,18 +57,26 @@ depends=(
## About ffmpeg-obs
# Read ffmpeg-obs PKGBUILD for more info
makedepends=(
- "cmake" "git" "libfdk-aac" "swig" "luajit" "sndio"
- "python>=$_pythonver"
-
- # Needed by obs-websocket
- 'asio' 'nlohmann-json' 'websocketpp'
-
- # AUR Packages
- "libajantv2"
-
+ "asio" # Deps of Websocket plugin (headers-only lib)
+ "cmake"
+ "jack" # Deps of JACK plugin
+ "git"
+ "libajantv2" # Deps of AJA plugin (static lib)
+ "libfdk-aac" # Deps of FDK AAC plugin
+ "luajit" # Deps of Scripting plugin
+ "nlohmann-json" # Deps of Websocket plugin (headers-only lib)
+ "python>=$_pythonver" # Deps of Scripting plugin
+ "sndio" # Deps of sndio plugin
+ "swig" # Deps of Scripting plugin
+ "systemd-libs" # Deps of V4L2 plugin
+ "v4l-utils" # Deps of V4L2 plugin
+ "websocketpp" # Deps of Websocket plugin (headers-only lib)
+
+ # Deps of obs-browser
"cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1"
)
optdepends=(
+ "jack: JACK support"
"libfdk-aac: FDK AAC codec support"
"intel-media-driver: Hardware encoding (>= Broadwell)"
"libva-intel-driver: Hardware encoding (<= Haswell)"
@@ -62,8 +85,9 @@ optdepends=(
"luajit: Lua scripting"
"python>=$_pythonver: Python scripting"
"sndio: Sndio input client"
- "v4l2loopback-dkms: Virtual camera output"
- "libajantv2: AJA NTV 2 support"
+ "v4l-utils: V4L2 support"
+ "systemd-libs: V4L2 support"
+ "v4l2loopback-dkms: V4L2 virtual camera output"
)
provides=("obs-studio=$pkgver" "obs-vst" "obs-websocket" "obs-browser")
conflicts=(
@@ -112,10 +136,7 @@ prepare() {
}
build() {
- cd "$srcdir"/obs-studio
- mkdir -p build; cd build
-
- cmake \
+ cmake -B build -S obs-studio \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -126,15 +147,14 @@ build() {
-DENABLE_SNDIO=ON \
-DENABLE_BROWSER=ON \
-DCEF_ROOT_DIR=/opt/cef-obs \
- -DOBS_VERSION_OVERRIDE="$pkgver" ..
+ -DOBS_VERSION_OVERRIDE="$pkgver" \
+ -Wno-dev
- sed -i "s|#define OBS_VERSION |#define OBS_VERSION \"$pkgver-tytan652-$pkgrel\" //|" config/obsconfig.h
+ sed -i "s|#define OBS_VERSION |#define OBS_VERSION \"$pkgver-tytan652-$pkgrel\" //|" build/config/obsconfig.h
- make
+ cmake --build build
}
package() {
- cd obs-studio/build
-
- make install DESTDIR="$pkgdir"
+ DESTDIR="$pkgdir" cmake --install build
}