summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCobalt Space2020-11-08 12:13:53 -0800
committerCobalt Space2020-11-08 12:13:53 -0800
commit538c99b12b85a4766153df2ca822e3be24865d6c (patch)
treec3030a1dfda7b6aaee84079b4f68f0f3347b5db0
downloadaur-538c99b12b85a4766153df2ca822e3be24865d6c.tar.gz
Create obs-studio-wayland-git
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD67
2 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e914d496985
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = obs-studio-wayland-git
+ pkgdesc = Free, open source software for live streaming and recording (with wayland patches)
+ pkgver = 26.0.2.r83.g5f6793676
+ pkgrel = 1
+ url = https://github.com/obsproject/obs-studio
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = libfdk-aac
+ makedepends = libxcomposite
+ makedepends = x264
+ makedepends = jack
+ makedepends = vlc
+ makedepends = swig
+ makedepends = luajit
+ makedepends = python
+ makedepends = cef-minimal-3770
+ depends = ffmpeg
+ depends = jansson
+ depends = libxinerama
+ depends = libxkbcommon-x11
+ depends = mbedtls
+ depends = qt5-svg
+ depends = qt5-x11extras
+ depends = curl
+ depends = jack
+ depends = gtk-update-icon-cache
+ optdepends = libfdk-aac: FDK AAC codec support
+ optdepends = libxcomposite: XComposite capture support
+ optdepends = libva-intel-driver: hardware encoding
+ optdepends = libva-mesa-driver: hardware encoding
+ optdepends = vlc: VLC Media Source
+ optdepends = swig: Scripting
+ optdepends = luajit: Lua scripting
+ optdepends = python: Python scripting
+ optdepends = qt5-wayland: Wayland obs window
+ optdepends = wlrobs-hg: screen capture on wlroots compositors
+ provides = obs-studio=26.0.2.r83.g5f6793676
+ provides = obs-studio-git
+ provides = obs-studio-wayland=26.0.2.r83.g5f6793676
+ conflicts = obs-studio
+ source = obs-studio-wayland-git::git+https://github.com/obsproject/obs-studio.git#branch=master
+ source = git+https://github.com/Mixer/ftl-sdk.git
+ source = git+https://github.com/obsproject/obs-browser.git
+ source = git+https://aur.archlinux.org/obs-studio-wayland.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = obs-studio-wayland-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cb7005db60c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Cobalt Space <cobaltspace at protonmail dot com>
+# Contributor: Benjamin Klettbach <b dot klettbach at gmail dot com >
+# Contributor: Antoine Damhet <xdbob at lse.epita.fr>
+# Contributor: Jonathan Steel <jsteel at archlinux.org>
+# Contributor: ArcticVanguard <LideEmily at gmail dot com>
+# Contributor: ledti <antergist at gmail dot com>
+pkgname=obs-studio-wayland-git
+pkgver=26.0.2.r83.g5f6793676
+pkgrel=1
+pkgdesc="Free, open source software for live streaming and recording (with wayland patches)"
+arch=("i686" "x86_64")
+url="https://github.com/obsproject/obs-studio"
+license=("GPL2")
+depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
+ "qt5-svg" "qt5-x11extras" "curl" "jack" "gtk-update-icon-cache")
+makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
+ "vlc" "swig" "luajit" "python" "cef-minimal-3770")
+optdepends=("libfdk-aac: FDK AAC codec support"
+ "libxcomposite: XComposite capture support"
+ "libva-intel-driver: hardware encoding"
+ "libva-mesa-driver: hardware encoding"
+ "vlc: VLC Media Source"
+ "swig: Scripting"
+ "luajit: Lua scripting"
+ "python: Python scripting"
+ "qt5-wayland: Wayland obs window"
+ "wlrobs-hg: screen capture on wlroots compositors")
+provides=("obs-studio=$pkgver" "obs-studio-git" "obs-studio-wayland=$pkgver")
+conflicts=("obs-studio")
+source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#branch=master"
+ "git+https://github.com/Mixer/ftl-sdk.git"
+ "git+https://github.com/obsproject/obs-browser.git"
+ "git+https://aur.archlinux.org/obs-studio-wayland.git")
+md5sums=("SKIP" "SKIP" "SKIP" "SKIP")
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+prepare() {
+ cd $pkgname
+ git config submodule.plugins/obs-outputs/ftl-sdk.url $srcdir/ftl-sdk
+ git config submodule.plugins/obs-browser.url $srcdir/obs-browser
+ git submodule update
+
+ for patch in $srcdir/obs-studio-wayland/*.patch; do
+ patch -Np1 -i "$patch"
+ done
+}
+
+build() {
+ cmake -S $pkgname -B build\
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_BROWSER=ON \
+ -DCEF_ROOT_DIR="/opt/cef" \
+ -DOBS_VERSION_OVERRIDE=$pkgver
+
+ make -C build
+}
+
+package() {
+ make -C build install DESTDIR="$pkgdir"
+}
+
+# vim: ts=2:sw=2:expandtab