summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Matias2021-01-11 09:03:09 -0300
committerPaulo Matias2021-01-11 09:03:09 -0300
commitf656933a4b2ab4bb0a3378588dfcb629db0ffd3b (patch)
tree212e86eeeeb41f7bd89c6b2360ad66c7a0cfa293
parent552dbdbb77c412308c7a8e6f47f8dcf3cead60d0 (diff)
downloadaur-f656933a4b2ab4bb0a3378588dfcb629db0ffd3b.tar.gz
Upgrade to latest git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--fix_python_binary_loading.patch24
-rw-r--r--rr-cache.tar.zstbin0 -> 4393 bytes
4 files changed, 56 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf9de735805e..695b34cd6b69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-wayland-git
pkgdesc = Free, open source software for live streaming and recording (with wayland patches)
- pkgver = 26.0.2.r83.g5f6793676
- pkgrel = 2
+ pkgver = 26.1.2.r27.g79f8b420f
+ pkgrel = 1
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -17,6 +17,7 @@ pkgbase = obs-studio-wayland-git
makedepends = luajit
makedepends = python
makedepends = cef-minimal-3770
+ makedepends = wayland
depends = ffmpeg
depends = jansson
depends = libxinerama
@@ -36,20 +37,21 @@ pkgbase = obs-studio-wayland-git
optdepends = luajit: Lua scripting
optdepends = python: Python scripting
optdepends = v4l2loopback-dkms: virtual webcam
- optdepends = qt5-wayland: wayland obs window
- optdepends = wlrobs-hg: screen capture on wlroots compositors
- provides = obs-studio=26.0.2.r83.g5f6793676
+ optdepends = wlrobs: screen capture on wlroots compositors
+ provides = obs-studio=26.1.2.r27.g79f8b420f
provides = obs-studio-git
- provides = obs-studio-wayland=26.0.2.r83.g5f6793676
+ provides = obs-studio-wayland=26.1.2.r27.g79f8b420f
conflicts = obs-studio
source = obs-studio-wayland-git::git+https://github.com/obsproject/obs-studio.git#branch=master
source = git+https://github.com/Mixer/ftl-sdk.git
source = git+https://github.com/obsproject/obs-browser.git
- source = git+https://aur.archlinux.org/obs-studio-wayland.git
- md5sums = SKIP
+ source = fix_python_binary_loading.patch
+ source = rr-cache.tar.zst
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 051b90f05e26bff99236b8fb1ad377d1
+ md5sums = b2c579e25a7884084701a71579e0b653
pkgname = obs-studio-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
index 4fbfb914a5a6..8dacea2a5150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: ArcticVanguard <LideEmily at gmail dot com>
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-wayland-git
-pkgver=26.0.2.r83.g5f6793676
-pkgrel=2
+pkgver=26.1.2.r27.g79f8b420f
+pkgrel=1
pkgdesc="Free, open source software for live streaming and recording (with wayland patches)"
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -14,7 +14,7 @@ license=("GPL2")
depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
"qt5-svg" "qt5-x11extras" "curl" "jack" "gtk-update-icon-cache")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
- "vlc" "swig" "luajit" "python" "cef-minimal-3770")
+ "vlc" "swig" "luajit" "python" "cef-minimal-3770" "wayland")
optdepends=("libfdk-aac: FDK AAC codec support"
"libxcomposite: XComposite capture support"
"libva-intel-driver: hardware encoding"
@@ -24,15 +24,19 @@ optdepends=("libfdk-aac: FDK AAC codec support"
"luajit: Lua scripting"
"python: Python scripting"
"v4l2loopback-dkms: virtual webcam"
- "qt5-wayland: wayland obs window"
- "wlrobs-hg: screen capture on wlroots compositors")
+ "wlrobs: screen capture on wlroots compositors")
provides=("obs-studio=$pkgver" "obs-studio-git" "obs-studio-wayland=$pkgver")
conflicts=("obs-studio")
source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#branch=master"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git"
- "git+https://aur.archlinux.org/obs-studio-wayland.git")
-md5sums=("SKIP" "SKIP" "SKIP" "SKIP")
+ "fix_python_binary_loading.patch"
+ "rr-cache.tar.zst")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ '051b90f05e26bff99236b8fb1ad377d1'
+ 'b2c579e25a7884084701a71579e0b653')
pkgver() {
cd $pkgname
@@ -45,10 +49,17 @@ prepare() {
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
git submodule update
- [ ! -e patched ] && for patch in $srcdir/obs-studio-wayland/*.patch; do
- patch -Np1 -i "$patch"
- done
- touch patched
+ # from https://github.com/obsproject/obs-studio/pull/2484
+ cp -a "$srcdir"/.git/rr-cache .git/
+ git config rerere.enabled true
+ git fetch origin pull/2484/head
+ git checkout -b wayland FETCH_HEAD
+ git merge master || true
+ [[ -z "$(git rerere status)" ]] || exit 1
+ git commit --all --no-edit
+
+ # from official arch package
+ patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
}
build() {
diff --git a/fix_python_binary_loading.patch b/fix_python_binary_loading.patch
new file mode 100644
index 000000000000..6cba55f2f1af
--- /dev/null
+++ b/fix_python_binary_loading.patch
@@ -0,0 +1,24 @@
+From c482159ce93deafc7f1fc5755ba15135709ae726 Mon Sep 17 00:00:00 2001
+From: Matt Gajownik <matt@obsproject.com>
+Date: Tue, 25 Aug 2020 19:28:26 +1000
+Subject: [PATCH] libobs/util: Fix loading Python binary modules on *nix
+
+Fixes #2222
+---
+ libobs/util/platform-nix.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/libobs/util/platform-nix.c b/libobs/util/platform-nix.c
+index 26800d52f7..997b62db1a 100644
+--- a/libobs/util/platform-nix.c
++++ b/libobs/util/platform-nix.c
+@@ -71,7 +71,8 @@ void *os_dlopen(const char *path)
+ #ifdef __APPLE__
+ void *res = dlopen(dylib_name.array, RTLD_LAZY | RTLD_FIRST);
+ #else
+- void *res = dlopen(dylib_name.array, RTLD_LAZY);
++ void *res = dlopen(dylib_name.array,
++ RTLD_LAZY | RTLD_DEEPBIND | RTLD_GLOBAL);
+ #endif
+ if (!res)
+ blog(LOG_ERROR, "os_dlopen(%s->%s): %s\n", path,
diff --git a/rr-cache.tar.zst b/rr-cache.tar.zst
new file mode 100644
index 000000000000..5780f92eeacf
--- /dev/null
+++ b/rr-cache.tar.zst
Binary files differ