summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-05-19 20:32:48 +0200
committertytan6522023-05-19 20:32:48 +0200
commit4973bc0f670aedfaa24ac0a66ca53783affab071 (patch)
treedb28a2ffcba70c5ec85f4cc20f636acba30f696b
parent025160764d4d7b765f63dc94569b68660a2a4231 (diff)
downloadaur-4973bc0f670aedfaa24ac0a66ca53783affab071.tar.gz
build: Update to 1.9.6
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f46033f0812..b05de2d2ba03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = obs-tuna
pkgdesc = Get song info from right within obs
- pkgver = 1.9.5
+ pkgver = 1.9.6
pkgrel = 1
url = https://obsproject.com/forum/resources/tuna.843/
arch = x86_64
arch = aarch64
license = GPL2
makedepends = cmake
- makedepends = vlc
makedepends = git
+ makedepends = vlc
depends = obs-studio>=28
+ depends = curl
+ depends = dbus
+ depends = gcc-libs
+ depends = glibc
depends = libmpdclient
+ depends = qt6-base
depends = taglib
conflicts = obs-plugin-tuna-bin
conflicts = obs-plugin-tuna-git
options = debug
- source = tuna::git+https://github.com/univrsal/tuna.git#tag=v1.9.5
+ source = tuna::git+https://github.com/univrsal/tuna.git#tag=v1.9.6
source = FindLibMPDClient.cmake
source = FindTaglib.cmake
source = deps_CMakeLists.txt
diff --git a/PKGBUILD b/PKGBUILD
index 26b25a180c58..9954401a6711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,17 @@ fi
_pluginname=tuna
pkgname=obs-$_pluginname
-pkgver=1.9.5
+pkgver=1.9.6
pkgrel=1
arch=("x86_64" "aarch64")
pkgdesc="Get song info from right within obs"
url="https://obsproject.com/forum/resources/tuna.843/"
license=('GPL2')
-depends=("obs-studio>=28" "libmpdclient" "taglib")
-makedepends=("cmake" "vlc" "git")
+depends=(
+ "obs-studio>=28" "curl" "dbus" "gcc-libs" "glibc" "libmpdclient"
+ "qt6-base" "taglib"
+)
+makedepends=("cmake" "git" "vlc")
conflicts=("obs-plugin-tuna-bin" "obs-plugin-tuna-git")
options=('debug')
source=(
@@ -44,20 +47,19 @@ prepare() {
}
build() {
- cd $_pluginname
- cmake -B build \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ cmake -B build -S $_pluginname \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
-DQT_VERSION=6 \
-DCREDS="$SPOTIFY_TOKEN" \
- -DLASTFM_CREDS="$LASTFM_KEY"
+ -DLASTFM_CREDS="$LASTFM_KEY" \
+ -Wno-dev
- make -C build
+ cmake --build build
}
package() {
- cd $_pluginname
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
} \ No newline at end of file