summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-09-01 11:43:22 +0200
committertytan6522022-09-01 11:43:22 +0200
commit50ade19df013c791dbe18c0a3998581b03fd7012 (patch)
tree59be1aa7125ef2cb2b4c5ccaa889e4b563f2eff1
parentfc79022b2d796f6bda15ae3ea4fce33916e83166 (diff)
downloadaur-50ade19df013c791dbe18c0a3998581b03fd7012.tar.gz
build: Update to 0.8.1
OBS Studio 28 and later is set because of the CMake and Qt changes between 27 and 28
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89aa9ff3f460..26fc308137e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-tuna
pkgdesc = Get song info from right within obs
- pkgver = 1.7.1
+ pkgver = 1.8.1
pkgrel = 1
url = https://obsproject.com/forum/resources/tuna.843/
arch = i686
@@ -10,13 +10,13 @@ pkgbase = obs-tuna
makedepends = cmake
makedepends = vlc
makedepends = git
- depends = obs-studio<28
+ depends = obs-studio>=28
depends = libmpdclient
depends = taglib
conflicts = obs-plugin-tuna-bin
conflicts = obs-plugin-tuna-git
options = debug
- source = tuna::git+https://github.com/univrsal/tuna.git#tag=v1.7.1
+ source = tuna::git+https://github.com/univrsal/tuna.git#tag=v1.8.1
source = FindLibMPDClient.cmake
source = FindTaglib.cmake
source = deps_CMakeLists.txt
diff --git a/PKGBUILD b/PKGBUILD
index fffa6d998dc3..dda52f9e5650 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,13 @@ fi
_pluginname=tuna
pkgname=obs-$_pluginname
-pkgver=1.7.1
+pkgver=1.8.1
pkgrel=1
arch=("i686" "x86_64" "aarch64")
pkgdesc="Get song info from right within obs"
url="https://obsproject.com/forum/resources/tuna.843/"
license=('GPL2')
-depends=("obs-studio<28" "libmpdclient" "taglib")
+depends=("obs-studio>=28" "libmpdclient" "taglib")
makedepends=("cmake" "vlc" "git")
conflicts=("obs-plugin-tuna-bin" "obs-plugin-tuna-git")
options=('debug')
@@ -40,22 +40,24 @@ prepare() {
cp $srcdir/FindTaglib.cmake cmake/external/.
cp $srcdir/deps_CMakeLists.txt deps/CMakeLists.txt
- sed -i '29 a find_package(LibMPDClient REQUIRED)\nfind_package(Taglib REQUIRED)\nfind_package(LibVLC REQUIRED)' CMakeLists.txt
- sed -i '40 a include_directories(${LIBVLC_INCLUDE_DIRS})' CMakeLists.txt
+ sed -i '13 a find_package(LibMPDClient REQUIRED)\nfind_package(Taglib REQUIRED)' CMakeLists.txt
}
build() {
cd $_pluginname
- cmake -B build\
+ cmake -B build \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DGLOBAL_INSTALLATION=ON \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DLINUX_PORTABLE=OFF \
+ -DQT_VERSION=6 \
-DCREDS="$SPOTIFY_TOKEN" \
-DLASTFM_CREDS="$LASTFM_KEY"
+
make -C build
}
package() {
cd $_pluginname
make -C build DESTDIR="$pkgdir/" install
-}
+} \ No newline at end of file