summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-03-09 21:45:49 +0100
committertytan6522024-03-09 21:45:49 +0100
commit68da1ef885e844821cfd32b939d75816eb05cc57 (patch)
tree6609576f4b94e141988a57c1f5830d5098ce6224
parentc94eb882d1c825f618566618bdfb50b91572eae1 (diff)
downloadaur-68da1ef885e844821cfd32b939d75816eb05cc57.tar.gz
build: Allow deprecated declarations the CMake way
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7ceab893b91..3933dae339ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,8 +47,6 @@ prepare() {
}
build() {
- export CXXFLAGS+=" -Wno-error=deprecated-declarations"
-
cmake -B build -S $_pluginname \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
@@ -57,7 +55,8 @@ build() {
-DQT_VERSION=6 \
-DCREDS="$SPOTIFY_TOKEN" \
-DLASTFM_CREDS="$LASTFM_KEY" \
- -Wno-dev
+ -Wno-dev \
+ -DCMAKE_CXX_FLAGS="-Wno-error=deprecated-declarations"
cmake --build build
}