summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-10-26 20:01:05 +0200
committertytan6522021-10-26 20:01:05 +0200
commit7ce8b33543758690a520d0100edb313a7569adc6 (patch)
treef2b663cbbf084e4b11d6de6705b22493fbe05375
downloadaur-7ce8b33543758690a520d0100edb313a7569adc6.tar.gz
build: Initial version 1.6.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD53
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..301a27e40999
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = obs-tuna
+ pkgdesc = Get song info from right within obs
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://obsproject.com/forum/resources/tuna.843/
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ depends = obs-studio
+ conflicts = obs-plugin-tuna-bin
+ conflicts = obs-plugin-tuna-git
+ source = tuna::git+https://git.vrsal.de/alex/tuna.git#tag=v1.6.1
+ source = git+https://github.com/taglib/taglib
+ source = git+https://github.com/MusicPlayerDaemon/libmpdclient
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = obs-tuna
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69e71cab8957
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
+
+# You can make those variable persistent by adding them to `~/.makepkg.conf`
+if [ -z "$SPOTIFY_TOKEN" ]; then
+ SPOTIFY_TOKEN="MISSING"
+fi
+
+if [ -z "$LASTFM_KEY" ]; then
+ LASTFM_KEY="MISSING"
+fi
+
+_pluginname=tuna
+pkgname=obs-$_pluginname
+pkgver=1.6.1
+pkgrel=1
+arch=("i686" "x86_64" "aarch64")
+pkgdesc="Get song info from right within obs"
+url="https://obsproject.com/forum/resources/tuna.843/"
+license=('GPL2')
+depends=("obs-studio")
+makedepends=("cmake" "git")
+conflicts=("obs-plugin-tuna-bin" "obs-plugin-tuna-git")
+source=(
+ "$_pluginname::git+https://git.vrsal.de/alex/tuna.git#tag=v$pkgver"
+ "git+https://github.com/taglib/taglib"
+ "git+https://github.com/MusicPlayerDaemon/libmpdclient")
+sha256sums=(
+ "SKIP"
+ "SKIP"
+ "SKIP"
+)
+
+prepare() {
+ cd $_pluginname
+ git config submodule.deps/taglib.url $srcdir/taglib
+ git config submodule.deps/libmpdclient.url $srcdir/libmpdclient
+ git submodule update
+}
+
+build() {
+ cd $_pluginname
+ cmake -B build\
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DGLOBAL_INSTALLATION=ON \
+ -DCREDS="$SPOTIFY_TOKEN" \
+ -DLASTFM_CREDS="$LASTFM_KEY"
+ make -C build
+}
+
+package() {
+ cd $_pluginname
+ make -C build DESTDIR="$pkgdir/" install
+}