summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-02-04 13:18:45 +0100
committertytan6522022-02-04 13:18:45 +0100
commita27370ad60ec52085e3b9796e1d34624207124ce (patch)
tree4e98b40197f0156bfdf0922d9d97419458c59a1b
parentc4a2b9ff292f94e0eb86736841fe4e1a99da76c5 (diff)
downloadaur-a27370ad60ec52085e3b9796e1d34624207124ce.tar.gz
build: Enable debug symbol
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acd379b6dcb8..e0d506462541 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-tuna
pkgdesc = Get song info from right within obs
pkgver = 1.6.1
- pkgrel = 3
+ pkgrel = 4
url = https://obsproject.com/forum/resources/tuna.843/
arch = i686
arch = x86_64
@@ -15,6 +15,7 @@ pkgbase = obs-tuna
depends = taglib
conflicts = obs-plugin-tuna-bin
conflicts = obs-plugin-tuna-git
+ options = debug
source = tuna::git+https://github.com/univrsal/tuna.git#tag=v1.6.1
source = FindLibMPDClient.cmake
source = FindTaglib.cmake
diff --git a/PKGBUILD b/PKGBUILD
index 2a82ccffd211..534cf6361ef3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ fi
_pluginname=tuna
pkgname=obs-$_pluginname
pkgver=1.6.1
-pkgrel=3
+pkgrel=4
arch=("i686" "x86_64" "aarch64")
pkgdesc="Get song info from right within obs"
url="https://obsproject.com/forum/resources/tuna.843/"
@@ -20,6 +20,7 @@ license=('GPL2')
depends=("obs-studio" "libmpdclient" "taglib")
makedepends=("cmake" "vlc" "git")
conflicts=("obs-plugin-tuna-bin" "obs-plugin-tuna-git")
+options=('debug')
source=(
"$_pluginname::git+https://github.com/univrsal/tuna.git#tag=v$pkgver"
"FindLibMPDClient.cmake"
@@ -46,6 +47,7 @@ prepare() {
build() {
cd $_pluginname
cmake -B build\
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DGLOBAL_INSTALLATION=ON \
-DCREDS="$SPOTIFY_TOKEN" \