summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-03-09 21:42:35 +0100
committertytan6522024-03-09 21:42:35 +0100
commitc94eb882d1c825f618566618bdfb50b91572eae1 (patch)
treee022a37a2a42d53959672e8da75b0aa816d91674
parent88e8bee31bd2fd80fbc85790ac23feabb101b524 (diff)
downloadaur-c94eb882d1c825f618566618bdfb50b91572eae1.tar.gz
build: Allow deprecated declarations
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4078eb02b9ba..f331eca931db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = obs-tuna
pkgdesc = Get song info from right within obs
pkgver = 1.9.7
- pkgrel = 1
+ pkgrel = 2
url = https://obsproject.com/forum/resources/tuna.843/
arch = x86_64
arch = aarch64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = cmake
makedepends = git
makedepends = vlc
diff --git a/PKGBUILD b/PKGBUILD
index 724300c32a10..d7ceab893b91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,11 @@ fi
_pluginname=tuna
pkgname=obs-$_pluginname
pkgver=1.9.7
-pkgrel=1
+pkgrel=2
arch=("x86_64" "aarch64")
pkgdesc="Get song info from right within obs"
url="https://obsproject.com/forum/resources/tuna.843/"
-license=('GPL2')
+license=(GPL-2.0-or-later)
depends=(
"obs-studio>=28" "curl" "dbus" "gcc-libs" "glibc" "libmpdclient"
"qt6-base" "taglib"
@@ -47,6 +47,8 @@ prepare() {
}
build() {
+ export CXXFLAGS+=" -Wno-error=deprecated-declarations"
+
cmake -B build -S $_pluginname \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
@@ -62,4 +64,4 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
-} \ No newline at end of file
+}