summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKnut Ahlers2020-05-02 15:24:22 +0200
committerKnut Ahlers2020-05-02 15:24:22 +0200
commit9320861bcaec80e504a465c33f72fa1c044eabe2 (patch)
tree82545f1f2faa5f05d92fdb244dbe1435d96e4767
parent7205d58149fd8c409a18ff2057e3e56c403c14e4 (diff)
downloadaur-9320861bcaec80e504a465c33f72fa1c044eabe2.tar.gz
Apply patch to avoid crash on capture stop
Signed-off-by: Knut Ahlers <knut@ahlers.me>
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a710d41e7ae5..169749d1e8ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,15 +23,22 @@ options=()
install=
changelog=
source=("$url/archive/$pkgver.tar.gz"
- "https://github.com/obsproject/obs-studio/archive/$obsver.tar.gz")
+ "https://github.com/obsproject/obs-studio/archive/$obsver.tar.gz"
+ "v4l2device_close.patch::https://github.com/CatxFish/obs-v4l2sink/pull/21.patch")
noextract=()
sha256sums=('83e9bb104dcc3840acd17ebc0810de30c8de27545d4ef181d58f8a375dba06d4'
- 'c8db224d2ee4d9b91448be9e47414398e570eebe4a59ff9fd19b066789d1ccdb')
+ 'c8db224d2ee4d9b91448be9e47414398e570eebe4a59ff9fd19b066789d1ccdb'
+ '617e017562ab3ca85fffa86c869fa778e26ee0694e0ae8dd1b8b110bff1bb6cc')
validpgpkeys=()
prepare() {
rm -rf build
mkdir build
+
+ # Apply "adjust v4l2device_close to void" patch from
+ # https://github.com/CatxFish/obs-v4l2sink/pull/21
+ cd $pkgname-$pkgver
+ patch --forward --fuzz=0 --input="${srcdir}/v4l2device_close.patch" --strip=1
}
build() {