summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2023-01-23 07:08:20 -0800
committerChristopher Snowhill2023-01-23 07:08:20 -0800
commitcb2eb7ef145000592cf35170462366ef341c6562 (patch)
tree79a80741661c6e1c39b4d99bbbb3a7d80b7efe1f
downloadaur-cb2eb7ef145000592cf35170462366ef341c6562.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16b248042b26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = obs-vaapi-git
+ pkgdesc = OBS Studio VAAPI support via GStreamer (git version)
+ pkgver = 0.1.0.r18.geb89a9e
+ pkgrel = 1
+ url = https://github.com/fzwoch/obs-vaapi
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL2
+ makedepends = git
+ makedepends = meson
+ depends = obs-studio
+ depends = gst-plugins-base-libs
+ depends = gstreamer-vaapi
+ depends = gst-plugin-va
+ provides = obs-vaapi
+ conflicts = obs-vaapi
+ source = git+https://github.com/fzwoch/obs-vaapi.git
+ sha256sums = SKIP
+
+pkgname = obs-vaapi-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92675915b208
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christopher Snowhill <kode54@gmail.com>
+# Contributor: Andrius Lukosevicius <niobium93@gmail.com>
+
+_pkgname=obs-vaapi
+pkgname=obs-vaapi-git
+pkgver=0.1.0.r18.geb89a9e
+pkgrel=1
+pkgdesc="OBS Studio VAAPI support via GStreamer (git version)"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/fzwoch/obs-vaapi"
+license=('GPL2')
+depends=('obs-studio' 'gst-plugins-base-libs' 'gstreamer-vaapi' 'gst-plugin-va')
+makedepends=('git' 'meson')
+conflicts=('obs-vaapi')
+provides=('obs-vaapi')
+source=("git+https://github.com/fzwoch/obs-vaapi.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ meson "$srcdir/$_pkgname" build --prefix=/usr --buildtype=release
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ # clean up after the new git design that tries to install to home directory
+ # partially fixed by the --prefix=/usr above
+ mkdir -p "$pkgdir/usr/lib/obs-plugins"
+ mv "$pkgdir/usr/obs-vaapi.so" "$pkgdir/usr/lib/obs-plugins"
+}