summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Greenough2018-02-18 19:58:55 +1100
committerLiam Greenough2018-02-18 19:58:55 +1100
commit0d1feafe15b60f6cf2d04584522baca4ff242d93 (patch)
tree85eb586f9657cd014645179b36ee56b0472ab4c0
parent4b689423b2ea090fa9c6f364a50999121a83ba86 (diff)
downloadaur-0d1feafe15b60f6cf2d04584522baca4ff242d93.tar.gz
Working now
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60321267ffaf..e4ebac0b291d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,8 @@ pkgbase = obs-websocket-git
conflicts = obs-websocket
source = git+https://github.com/jp9000/obs-studio.git
source = git+https://github.com/Palakis/obs-websocket.git
+ source = git+https://github.com/ARMmbed/mbedtls
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 078876f0df38..8afcbb901054 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ depends=('obs-studio-git' 'qt5-websockets')
makedepends=('git' 'cmake')
provides=('obs-websocket')
conflicts=('obs-websocket')
-source=('git+https://github.com/jp9000/obs-studio.git' 'git+https://github.com/Palakis/obs-websocket.git')
-md5sums=('SKIP' 'SKIP')
+source=('git+https://github.com/jp9000/obs-studio.git' 'git+https://github.com/Palakis/obs-websocket.git' 'git+https://github.com/ARMmbed/mbedtls')
+md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/obs-websocket"
@@ -19,6 +19,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare(){
+cd "$srcdir/obs-websocket"
+git submodule init
+git config submodule."deps/mbedtls".url $srcdir/mbedtls
+git submodule update
+}
+
build() {
cd "$srcdir/obs-websocket"
mkdir build || true