summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorentriphy2022-07-02 16:57:21 -0700
committerentriphy2022-07-02 16:57:21 -0700
commit41c2a3cbe6bfda44e566cca04a04f996f901a176 (patch)
tree413a069a7278bbbc2dfb612d342d5e822bb7e5eb
parent0d1feafe15b60f6cf2d04584522baca4ff242d93 (diff)
downloadaur-41c2a3cbe6bfda44e566cca04a04f996f901a176.tar.gz
Update to 5.0.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD50
2 files changed, 49 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4ebac0b291d..80b9d75727f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = obs-websocket-git
- pkgdesc = Remote control of OBS Studio made easy
- pkgver = r569.357691b
+ pkgdesc = Remote-control of OBS Studio through WebSocket
+ pkgver = r665.a25427c
pkgrel = 1
- url = https://github.com/Palakis/obs-websocket
+ url = https://github.com/obsproject/obs-websocket
arch = i686
arch = x86_64
license = GPL2
makedepends = git
makedepends = cmake
- depends = obs-studio-git
- depends = qt5-websockets
+ depends = obs-studio
provides = obs-websocket
conflicts = obs-websocket
- source = git+https://github.com/jp9000/obs-studio.git
- source = git+https://github.com/Palakis/obs-websocket.git
- source = git+https://github.com/ARMmbed/mbedtls
+ source = git+https://github.com/obsproject/obs-websocket.git#branch=release/5.0.0
+ source = git+https://github.com/obsproject/obs-studio.git
+ source = git+https://github.com/chriskohlhoff/asio.git
+ source = git+https://github.com/nlohmann/json.git
+ source = git+https://github.com/nayuki/QR-Code-generator.git
+ source = git+https://github.com/zaphoyd/websocketpp.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
pkgname = obs-websocket-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8afcbb901054..6916d7dd5c0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,51 @@
-# Maintainer: Liam Greenough <beacon515@gmail.com>
+# Maintainer: entriphy <t4ils.dev@gmail.com>
+# Contributor: Liam Greenough <beacon515@gmail.com>
+
pkgname=obs-websocket-git
-pkgver=r569.357691b
+pkgver=r665.a25427c
pkgrel=1
-pkgdesc="Remote control of OBS Studio made easy"
+pkgdesc="Remote-control of OBS Studio through WebSocket"
arch=('i686' 'x86_64')
-url="https://github.com/Palakis/obs-websocket"
+url="https://github.com/obsproject/obs-websocket"
license=('GPL2')
-depends=('obs-studio-git' 'qt5-websockets')
+depends=('obs-studio')
makedepends=('git' 'cmake')
provides=('obs-websocket')
conflicts=('obs-websocket')
-source=('git+https://github.com/jp9000/obs-studio.git' 'git+https://github.com/Palakis/obs-websocket.git' 'git+https://github.com/ARMmbed/mbedtls')
-md5sums=('SKIP' 'SKIP' 'SKIP')
+source=(
+ 'git+https://github.com/obsproject/obs-websocket.git#branch=release/5.0.0' # Use release/5.0.0 since master compiles as a submodule for OBS Studio
+ 'git+https://github.com/obsproject/obs-studio.git'
+ 'git+https://github.com/chriskohlhoff/asio.git'
+ 'git+https://github.com/nlohmann/json.git'
+ 'git+https://github.com/nayuki/QR-Code-generator.git'
+ 'git+https://github.com/zaphoyd/websocketpp.git'
+)
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd "$srcdir/obs-websocket"
-# Git, no tags available
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare(){
-cd "$srcdir/obs-websocket"
-git submodule init
-git config submodule."deps/mbedtls".url $srcdir/mbedtls
-git submodule update
+prepare() {
+ cd "$srcdir/obs-websocket"
+ git submodule init
+ git config submodule."deps/asio".url $srcdir/asio
+ git config submodule."deps/json".url $srcdir/json
+ git config submodule."deps/qr".url $srcdir/QR-Code-generator
+ git config submodule."deps/websocketpp".url $srcdir/websocketpp
+
+ # Checkout all submodules except asio
+ # asio is locked to 1.12.0 in the repo due to a bug that only affects MacOS,
+ # though causes issues on Linux due to the -Werror flag
+ git submodule update deps/json deps/qr deps/websocketpp
}
build() {
@@ -31,7 +53,7 @@ build() {
mkdir build || true
cd build
cmake -DLIBOBS_INCLUDE_DIR="$srcdir/obs-studio/libobs/" -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ make -j$(nproc)
}
package() {