summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Greenough2018-02-18 19:12:49 +1100
committerLiam Greenough2018-02-18 19:12:49 +1100
commit4b689423b2ea090fa9c6f364a50999121a83ba86 (patch)
tree119e2ef07173c6db81b2dbcda3fcce692e3d58c9
parentadd944a3d3e6c0a183e22eadc69fa029a5eaf541 (diff)
downloadaur-4b689423b2ea090fa9c6f364a50999121a83ba86.tar.gz
Hopeful fix?
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5cc0dedfb00..60321267ffaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-websocket-git
pkgdesc = Remote control of OBS Studio made easy
- pkgver = VERSION
+ pkgver = r569.357691b
pkgrel = 1
url = https://github.com/Palakis/obs-websocket
arch = i686
@@ -8,12 +8,14 @@ pkgbase = obs-websocket-git
license = GPL2
makedepends = git
makedepends = cmake
- depends = obs-studio
+ depends = obs-studio-git
depends = qt5-websockets
provides = obs-websocket
conflicts = obs-websocket
+ source = git+https://github.com/jp9000/obs-studio.git
source = git+https://github.com/Palakis/obs-websocket.git
md5sums = SKIP
+ md5sums = SKIP
pkgname = obs-websocket-git
diff --git a/PKGBUILD b/PKGBUILD
index 1a704c2e7644..078876f0df38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Liam Greenough <beacon515@gmail.com>
pkgname=obs-websocket-git
-pkgver=VERSION
+pkgver=r569.357691b
pkgrel=1
pkgdesc="Remote control of OBS Studio made easy"
arch=('i686' 'x86_64')
url="https://github.com/Palakis/obs-websocket"
license=('GPL2')
-depends=('obs-studio' 'qt5-websockets')
+depends=('obs-studio-git' 'qt5-websockets')
makedepends=('git' 'cmake')
provides=('obs-websocket')
conflicts=('obs-websocket')
-source=('git+https://github.com/Palakis/obs-websocket.git')
-md5sums=('SKIP')
+source=('git+https://github.com/jp9000/obs-studio.git' 'git+https://github.com/Palakis/obs-websocket.git')
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "$srcdir/obs-websocket"
@@ -21,8 +21,9 @@ pkgver() {
build() {
cd "$srcdir/obs-websocket"
- mkdir build && cd build
- cmake -DLIBOBS_INCLUDE_DIR="/usr/share/obs/libobs" -DCMAKE_INSTALL_PREFIX=/usr ..
+ mkdir build || true
+ cd build
+ cmake -DLIBOBS_INCLUDE_DIR="$srcdir/obs-studio/libobs/" -DCMAKE_INSTALL_PREFIX=/usr ..
make
}