summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-11-05 02:28:39 +0100
committerFabioLolix2017-11-05 02:28:39 +0100
commit0749d0aa977cf96626a8828d9eb9fb9d85e8256e (patch)
tree873663da7d8f98766b74375bb5ce65736448fc4a
downloadaur-0749d0aa977cf96626a8828d9eb9fb9d85e8256e.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ebe5eea27bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = obsidian-2-theme-git
+ pkgdesc = Obsidian 2 theme for Gnome 3.22+
+ pkgver = v2.3.1.r0.g674abd0
+ pkgrel = 1
+ url = https://www.gnome-look.org/p/1173113/
+ arch = any
+ license = GPL3
+ optdepends = gnome-tweak-tool: A tool to customize advanced GNOME 3 options.
+ options = !strip
+ source = obsidian-2-theme-git::git+https://github.com/madmaxms/theme-obsidian-2.git
+ source = https://github.com/madmaxms/theme-obsidian-2/archive/green.zip
+ source = https://github.com/madmaxms/theme-obsidian-2/archive/amber.zip
+ source = https://github.com/madmaxms/theme-obsidian-2/archive/red.zip
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = obsidian-2-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7cbc9e63c37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Contributor: Matt Harrison <matt@harrison.us.com>
+# Contributor: scan
+
+pkgname=obsidian-2-theme-git
+pkgver=v2.3.1.r0.g674abd0
+pkgrel=1
+pkgdesc="Obsidian 2 theme for Gnome 3.22+"
+arch=('any')
+url="https://www.gnome-look.org/p/1173113/"
+license=('GPL3')
+optdepends=('gnome-tweak-tool: A tool to customize advanced GNOME 3 options.')
+options=(!strip)
+source=("${pkgname}::git+https://github.com/madmaxms/theme-obsidian-2.git"
+ "https://github.com/madmaxms/theme-obsidian-2/archive/green.zip"
+ "https://github.com/madmaxms/theme-obsidian-2/archive/amber.zip"
+ "https://github.com/madmaxms/theme-obsidian-2/archive/red.zip")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/themes
+ cp -r ${srcdir}/${pkgname}/Obsidian-2/ ${pkgdir}/usr/share/themes/Obsidian-2/
+ cp -r ${srcdir}/theme-obsidian-2-{amber,green,red}/Obsidian* ${pkgdir}/usr/share/themes/
+
+ find ${pkgdir} -type f -exec chmod 644 {} \;
+ find ${pkgdir} -type d -exec chmod 755 {} \;
+}