summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse R. Adams2015-08-08 06:54:12 -0700
committerJesse R. Adams2015-08-08 06:54:12 -0700
commit7a1e3a8f6d6887744740ca0af6603891fe06af47 (patch)
tree4a78ab91b21cedfdde64b38ef02c95f089ede689
downloadaur-7a1e3a8f6d6887744740ca0af6603891fe06af47.tar.gz
Initial import for AUR4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..476af5e1697b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = obvious-git
+ pkgdesc = Widgets for awesome wm (latest version)
+ pkgver = 20100621
+ pkgrel = 1
+ url = https://github.com/hoelzro/obvious
+ arch = any
+ license = custom:MIT
+ makedepends = git
+ depends = awesome
+
+pkgname = obvious-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..326efcc59d96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jesse R. Adams <jesse -at- techno -dash- geeks -dot- org>
+pkgname=obvious-git
+pkgver=20100621
+pkgrel=1
+pkgdesc="Widgets for awesome wm (latest version)"
+arch=(any)
+url="https://github.com/hoelzro/obvious"
+license=('custom:MIT')
+depends=('awesome')
+makedepends=('git')
+source=()
+md5sums=()
+
+_gitroot=https://github.com/hoelzro/obvious.git
+_gitname=obvious
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+ install -d ${pkgdir}/usr/share/awesome/lib/${_gitname} || return 1
+ cp -a ${_gitname}/* ${pkgdir}/usr/share/awesome/lib/${_gitname} || return 1
+ rm ${pkgdir}/usr/share/awesome/lib/${_gitname}/{AUTHORS,CONTRIBUTING.md,LICENSE,TODO} || return 1
+ install -Dm644 ${_gitname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+}