summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStevesAMonkey2019-04-29 09:33:38 +0930
committerStevesAMonkey2019-04-29 09:33:38 +0930
commit75d9c9b38c978ca8a8dd72be3069d67f7b72ba1b (patch)
tree9f23d825b9286287bf9270df264b8dd88127ad86
downloadaur-75d9c9b38c978ca8a8dd72be3069d67f7b72ba1b.tar.gz
Obyte 2.7.0
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD41
-rw-r--r--obyte-gui-wallet-bin.install16
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..142fb66b101a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = obyte-gui-wallet-bin
+ pkgdesc = Obyte cryptocurrency wallet client.
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = byteball.org
+ install = obyte-gui-wallet-bin.install
+ arch = x86_64
+ license = MIT
+ depends = binutils
+ depends = unzip
+ depends = freetype2
+ depends = nss
+ depends = gconf
+ depends = fontconfig
+ depends = pango
+ depends = libxi
+ depends = libxcursor
+ depends = libxss
+ depends = libxcomposite
+ depends = alsa-lib
+ depends = libxdamage
+ depends = libxtst
+ depends = atk
+ depends = libxrandr
+ depends = libcups
+ depends = gtk2
+ depends = libexif
+ options = !strip
+ source = https://github.com/byteball/obyte-gui-wallet/releases/download/v2.7.0/obyte-linux64.zip
+ sha256sums = f8d286bfb0247a730c4797128712b10c67a19ec4c5e6312c30e903de507b8b83
+
+pkgname = obyte-gui-wallet-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b2ea5de263f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Stephen Argent <steve [at] tuxcon [dot] com>
+
+pkgname=('obyte-gui-wallet-bin')
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="Obyte cryptocurrency wallet client."
+arch=('x86_64')
+url='byteball.org'
+license=('MIT')
+options=('!strip')
+depends=('binutils'
+ 'unzip'
+ 'freetype2'
+ 'nss'
+ 'gconf'
+ 'fontconfig'
+ 'pango'
+ 'libxi'
+ 'libxcursor'
+ 'libxss'
+ 'libxcomposite'
+ 'alsa-lib'
+ 'libxdamage'
+ 'libxtst'
+ 'atk'
+ 'libxrandr'
+ 'libcups'
+ 'gtk2'
+ 'libexif')
+source=(https://github.com/byteball/obyte-gui-wallet/releases/download/v${pkgver}/obyte-linux64.zip)
+sha256sums=('f8d286bfb0247a730c4797128712b10c67a19ec4c5e6312c30e903de507b8b83')
+install="$pkgname.install"
+package() {
+ unzip -o "${srcdir}/obyte-linux64.zip"
+ install -dm755 "$pkgdir/usr/share/obyte"
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -Dm644 "$srcdir/obyte-linux64/obyte.desktop" "$pkgdir/usr/share/applications/obyte.desktop"
+ cp -R ${srcdir}/obyte-linux64/* ${pkgdir}/usr/share/obyte/
+ chmod -R o+r "$pkgdir/usr/share/"
+ chmod 755 "$pkgdir/usr/share/obyte/Obyte"
+}
diff --git a/obyte-gui-wallet-bin.install b/obyte-gui-wallet-bin.install
new file mode 100644
index 000000000000..e037f5668fbd
--- /dev/null
+++ b/obyte-gui-wallet-bin.install
@@ -0,0 +1,16 @@
+post_install() {
+ if [ ! -f /usr/bin/obyte ]; then
+ ln -s /usr/share/obyte/Obyte /usr/bin/obyte
+ fi
+}
+
+post_upgrade() {
+ if [ ! -f /usr/bin/obyte ]; then
+ rm -f /usr/bin/byteball
+ ln -s /usr/share/obyte/Obyte /usr/bin/obyte
+ fi
+}
+
+post_remove() {
+ rm -f /usr/bin/obyte
+}