summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302020-05-09 15:40:53 +0200
committerM0Rf302020-05-09 15:40:53 +0200
commit1501fe92363b0b87dab358b3458f3e8bf4ad4af2 (patch)
tree0c918a04207d75f2b195ce5fc7f8302a205940cf
parent5890f16b6619b9e1d792d9b8ab5cda750d21b1e9 (diff)
downloadaur-1501fe92363b0b87dab358b3458f3e8bf4ad4af2.tar.gz
ocaml-alsa: fixed build system
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cc7ec4560c5..4c25a569f1bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
-# Generated by mksrcinfo v8
-# Tue Jun 6 09:12:26 UTC 2017
pkgbase = ocaml-alsa
pkgdesc = OCaml ALSA bindings
pkgver = 0.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/savonet/ocaml-alsa
arch = i686
arch = x86_64
license = GPL2
- makedepends = ocaml-findlib
+ makedepends = dune
+ makedepends = dune-configurator
depends = ocaml
depends = alsa-lib
options = !strip
- source = https://github.com/savonet/ocaml-alsa/releases/download/0.2.3/ocaml-alsa-0.2.3.tar.gz
- md5sums = bf14e0c419a8141a56a1cede08577843
+ options = !makeflags
+ source = ocaml-alsa-0.2.3::git+https://github.com/savonet/ocaml-alsa.git#commit=8e5578d2bc80c4ecb01ebf9d0f642db840ae46f1
+ md5sums = SKIP
pkgname = ocaml-alsa
diff --git a/PKGBUILD b/PKGBUILD
index f2dedf0dc29d..947255f4d6ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: robertfoster
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-alsa
pkgver=0.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="OCaml ALSA bindings"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-alsa"
license=('GPL2')
depends=('ocaml' 'alsa-lib')
-makedepends=('ocaml-findlib')
-options=('!strip')
-source=("https://github.com/savonet/ocaml-alsa/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('bf14e0c419a8141a56a1cede08577843')
+makedepends=('dune' 'dune-configurator')
+options=('!strip' '!makeflags')
+source=("${pkgname}-${pkgver}::git+https://github.com/savonet/ocaml-alsa.git#commit=8e5578d2bc80c4ecb01ebf9d0f642db840ae46f1")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure
- make
+ dune build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
}
+md5sums=('SKIP')