summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 21:07:19 +0100
committerGianluca Boiano2021-02-28 21:07:19 +0100
commit55d11cf631e78b7bb5a9eede59082463013dc0de (patch)
treefb25c96d2083eb51cbe2447415573281fa6c2580
parent8b4a811d5c1bd04418355e2a288106ce59c0fa3f (diff)
downloadaur-55d11cf631e78b7bb5a9eede59082463013dc0de.tar.gz
ocaml-alsa: fix for required commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d358a468b698..9ea31be4d8e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-alsa
pkgdesc = OCaml ALSA bindings
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/savonet/ocaml-alsa
arch = i686
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = ocaml-alsa
depends = alsa-lib
options = !strip
options = !makeflags
- source = https://github.com/savonet/ocaml-alsa/archive/0.3.0.tar.gz
- sha256sums = b0fd83b4b3a8e77a1d56d23f9864f1d44f32607369e37528fd4350b1d67222ed
+ source = https://github.com/savonet/ocaml-alsa/archive/8ffe8abc1cb4907c6be801c5af32a41defaefe54.tar.gz
+ sha256sums = fda8ba6dcfcf25b9aa402a1fe13f7d829e28c4436258bf8da6cf3bf43f3c3bb1
pkgname = ocaml-alsa
diff --git a/PKGBUILD b/PKGBUILD
index 00f518383382..db34e967c209 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ocaml-alsa
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="OCaml ALSA bindings"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-alsa"
@@ -11,17 +11,18 @@ license=('GPL2')
depends=('ocaml' 'alsa-lib')
makedepends=('dune')
options=('!strip' '!makeflags')
-source=("https://github.com/savonet/${pkgname}/archive/${pkgver}.tar.gz")
+_commit=8ffe8abc1cb4907c6be801c5af32a41defaefe54
+source=("https://github.com/savonet/${pkgname}/archive/${_commit}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_commit}"
dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_commit}"
dune install --prefix "${pkgdir}/usr" \
--libdir "${pkgdir}$(ocamlfind printconf destdir)"
}
-sha256sums=('b0fd83b4b3a8e77a1d56d23f9864f1d44f32607369e37528fd4350b1d67222ed')
+sha256sums=('fda8ba6dcfcf25b9aa402a1fe13f7d829e28c4436258bf8da6cf3bf43f3c3bb1')