summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 21:49:02 +0100
committerGianluca Boiano2021-02-28 21:49:02 +0100
commitba67ab6e7f125f80ef3a8802f0c2b23d9c01ff85 (patch)
tree5d264e4b659a7ae430ae0774be07b09be958cf9d
parent55d11cf631e78b7bb5a9eede59082463013dc0de (diff)
downloadaur-ba67ab6e7f125f80ef3a8802f0c2b23d9c01ff85.tar.gz
ocaml-alsa: fix for required commit
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ea31be4d8e0..576e83e024a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = ocaml-alsa
pkgdesc = OCaml ALSA bindings
pkgver = 0.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/savonet/ocaml-alsa
arch = i686
arch = x86_64
license = GPL2
+ makedepends = ocaml-findlib
makedepends = dune
depends = ocaml
depends = alsa-lib
options = !strip
options = !makeflags
- source = https://github.com/savonet/ocaml-alsa/archive/8ffe8abc1cb4907c6be801c5af32a41defaefe54.tar.gz
+ source = https://github.com/savonet/ocaml-alsa/archive/.tar.gz
sha256sums = fda8ba6dcfcf25b9aa402a1fe13f7d829e28c4436258bf8da6cf3bf43f3c3bb1
pkgname = ocaml-alsa
diff --git a/PKGBUILD b/PKGBUILD
index db34e967c209..2bc8424304a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,29 @@
pkgname=ocaml-alsa
pkgver=0.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="OCaml ALSA bindings"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-alsa"
license=('GPL2')
depends=('ocaml' 'alsa-lib')
-makedepends=('dune')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip' '!makeflags')
-_commit=8ffe8abc1cb4907c6be801c5af32a41defaefe54
source=("https://github.com/savonet/${pkgname}/archive/${_commit}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${_commit}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
dune build
}
package() {
- cd "${srcdir}/${pkgname}-${_commit}"
- dune install --prefix "${pkgdir}/usr" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
sha256sums=('fda8ba6dcfcf25b9aa402a1fe13f7d829e28c4436258bf8da6cf3bf43f3c3bb1')