summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 13:21:44 +0200
committerJ5lx2015-10-10 13:21:44 +0200
commit4da334b9d7dd56c5337851f6c27f898789126194 (patch)
treea73c6eb4144d357678283d09fffc7de8639f4702
downloadaur-4da334b9d7dd56c5337851f6c27f898789126194.tar.gz
0.2.1-1: Initial package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9684d6fc25f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-ao
+ pkgdesc = OCaml libao bindings
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-ao
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = libao
+ options = !strip
+ source = https://github.com/savonet/ocaml-ao/releases/download/0.2.1/ocaml-ao-0.2.1.tar.gz
+ md5sums = 7f763e8c47e8369274ee400c640532d4
+
+pkgname = ocaml-ao
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52d986a37892
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ao
+pkgver=0.2.1
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml libao bindings")
+url="https://github.com/savonet/ocaml-ao"
+depends=('ocaml' 'libao')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-ao/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('7f763e8c47e8369274ee400c640532d4')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}