summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-15 10:09:49 +0200
committerJakob Gahde2019-05-15 10:09:49 +0200
commit22bebe4dc9b19dd7b14fccb2e93e98e248093a64 (patch)
treeafbbb0cbf7a97a37ebe2df692554de73e078bbc8
parent1389e61d980d08a44f10e448e78d777aca39952c (diff)
downloadaur-22bebe4dc9b19dd7b14fccb2e93e98e248093a64.tar.gz
ocaml-bin_prot 1:0.12.0-1: New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be7bd87fd19c..1df4a7318921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ocaml-bin_prot
pkgdesc = A binary protocol generator
- pkgver = 0.11.0
- pkgrel = 2
+ pkgver = 0.12.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/bin_prot
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
@@ -15,11 +15,9 @@ pkgbase = ocaml-bin_prot
depends = ocaml-ppx_fields_conv
depends = ocaml-ppx_sexp_conv
depends = ocaml-ppx_variants_conv
- depends = ocaml-migrate-parsetree
- depends = ocaml-ppxlib
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/bin_prot-v0.11.0.tar.gz
- md5sums = 64495e0e88fe7cccba6e66b0deaef283
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/bin_prot-v0.12.0.tar.gz
+ sha512sums = e2a35ca27f80c8a79a75017e30e277489a5f64716764da02b2de21500ba6709a440113bc6d33d07db9dcf81f02bd62670b9b310e36c9807e818d8e03e7f79300
pkgname = ocaml-bin_prot
diff --git a/PKGBUILD b/PKGBUILD
index 172bdf5081e2..1be1aa683936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-bin_prot
-pkgver=0.11.0
-pkgrel=2
+pkgver=0.12.0
+pkgrel=1
epoch=1
pkgdesc="A binary protocol generator"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/bin_prot"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_custom_printf' 'ocaml-ppx_fields_conv' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_variants_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_custom_printf' 'ocaml-ppx_fields_conv' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_variants_conv')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/bin_prot-v${pkgver}.tar.gz")
-md5sums=('64495e0e88fe7cccba6e66b0deaef283')
+sha512sums=('e2a35ca27f80c8a79a75017e30e277489a5f64716764da02b2de21500ba6709a440113bc6d33d07db9dcf81f02bd62670b9b310e36c9807e818d8e03e7f79300')
build() {
cd "${srcdir}/bin_prot-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/bin_prot-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}