summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-03 17:28:56 +0200
committerJ5lx2015-07-03 17:28:56 +0200
commit44d301f35647c565c2a7e7d3d85fcf3e5d012b78 (patch)
tree0a94a3b526767386369a8c9ca73764e0b3fbf278
downloadaur-44d301f35647c565c2a7e7d3d85fcf3e5d012b78.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a799a8e2234
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ocaml-bin_prot
+ pkgdesc = A binary protocol generator
+ pkgver = 112.35.00
+ pkgrel = 1
+ url = https://github.com/janestreet/bin_prot
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = camlp4
+ depends = ocaml-type_conv
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/112.35/files/bin_prot-112.35.00.tar.gz
+ md5sums = c6f5f10c475d80eac8b0f3d39b33c6ab
+
+pkgname = ocaml-bin_prot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e0b75722b9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-bin_prot
+pkgver=112.35.00
+pkgrel=1
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="A binary protocol generator"
+url="https://github.com/janestreet/bin_prot"
+depends=('ocaml' 'camlp4' 'ocaml-type_conv')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz")
+options=('!strip')
+md5sums=('c6f5f10c475d80eac8b0f3d39b33c6ab')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "$OCAMLFIND_DESTDIR/stublibs"
+ DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" \
+ make install
+}