summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-21 22:45:25 +0100
committerDaniel Peukert2020-03-21 22:45:25 +0100
commit76e422dfa5e9a66e6c4ca52e6ed9bc40bbaff0ec (patch)
tree7f9bfa48cf0c02db89920566b62fd7e8909d2ecf
parent906b5f36708eedcd0b472bdc20801e7746766ccd (diff)
downloadaur-76e422dfa5e9a66e6c4ca52e6ed9bc40bbaff0ec.tar.gz
Fix licenses for ocaml-bin_prot and ocaml-lwt_log
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5966e6d8de3..49286ee3785a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,8 +35,12 @@ package() {
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
rm -r "$pkgdir/usr/doc/"
+ for _copy in 'COPYRIGHT.txt' 'THIRD-PARTY.txt'; do
+ install -Dm644 "$copy" "$pkgdir/usr/share/doc/$pkgname/$copy"
+ done
+
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- for _license in 'LICENSE.md' 'LICENSE-Tywith.txt'; do
+ for _license in 'COPYRIGHT.txt' 'LICENSE.md' 'LICENSE-Tywith.txt' 'THIRD-PARTY.txt'; do
ln -sf "/usr/share/doc/$pkgname/$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"
done
}