summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Bandel2015-11-07 01:26:32 +0100
committerOliver Bandel2015-11-07 01:26:32 +0100
commita9bedb20e761a9421ac2210345819a4f1e7ade63 (patch)
treeda5cf3fb43679d06e92937cc161cb1b9ed742b87
downloadaur-a9bedb20e761a9421ac2210345819a4f1e7ade63.tar.gz
Initial commit with orig sources used (no patches, as opam has)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e943d30e1894
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ocaml-camlzip
+ pkgdesc = Provides easy access to compressed files in ZIP, GZIP and JAR format
+ pkgver = 1.05
+ pkgrel = 1
+ url = http://forge.ocamlcore.org/projects/camlzip/
+ arch = i686
+ arch = x86_64
+ license = custom: LGPL-2.1+ with OCaml linking exception
+ makedepends = ocaml
+ makedepends = ocaml-findlib
+ depends = ocaml
+ source = http://forge.ocamlcore.org/frs/download.php/1037/camlzip-1.05.tar.gz
+ md5sums = e85c179d5dc79821e6e8d90e636599f1
+
+pkgname = ocaml-camlzip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52f45d8fefd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: oliver < a t > first . in-berlin . de
+pkgname=ocaml-camlzip
+_pkgname=camlzip
+pkgver=1.05
+pkgrel=1
+pkgdesc="Provides easy access to compressed files in ZIP, GZIP and JAR format"
+arch=('i686' 'x86_64')
+license=('custom: LGPL-2.1+ with OCaml linking exception')
+source=(http://forge.ocamlcore.org/frs/download.php/1037/camlzip-1.05.tar.gz)
+md5sums=(e85c179d5dc79821e6e8d90e636599f1)
+url="http://forge.ocamlcore.org/projects/camlzip/"
+depends=('ocaml')
+makedepends=('ocaml' 'ocaml-findlib')
+# options=(!makeflags)
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ make all
+ make allopt
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ INSTALLDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "$INSTALLDIR"
+ chmod 755 "$INSTALLDIR"
+
+ env DESTDIR=${pkgdir} \
+ OCAMLFIND_DESTDIR=${pkgdir}$(ocamlfind printconf destdir) \
+ OCAMLFIND_LDCONF=ignore \
+ ocamlfind install zip META *.mli *.a *.cmi *.cma $(wildcard *.cmxa) $(wildcard *.so)
+
+}