summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2021-02-12 13:27:51 -0500
committerSean Anderson2021-02-12 13:28:01 -0500
commitcb0eb89fb1a0f09434cd5ed0ebf683f1dec19629 (patch)
tree285a32eb084a19bafd4aa2c6b678767ebe61cf5b
parent7e41b37470a7fe32cd7f97e52b0cf4cc1f9e97ba (diff)
downloadaur-cb0eb89fb1a0f09434cd5ed0ebf683f1dec19629.tar.gz
Rename to ocaml-camlzip
This follows the OCaml packaging guidelines [1]. [1] https://wiki.archlinux.org/index.php/OCaml_package_guidelines#Package_naming
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fddcebbc2188..f43c3978eb86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ocaml-zip
+pkgbase = ocaml-camlzip
pkgdesc = ZIP and gzip library for OCaml
pkgver = 1.10
pkgrel = 1
@@ -9,10 +9,13 @@ pkgbase = ocaml-zip
makedepends = ocaml-findlib
depends = ocaml
depends = zlib
+ provides = ocaml-zip
+ conflicts = ocaml-zip
+ replaces = ocaml-zip
options = !strip
options = staticlibs
source = https://github.com/xavierleroy/camlzip/archive/rel110.tar.gz
md5sums = 97efd563735b4b6e7ae463b91aa72405
-pkgname = ocaml-zip
+pkgname = ocaml-camlzip
diff --git a/PKGBUILD b/PKGBUILD
index d57f1d2c737b..a806234112e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,10 @@
# Contributor: Sergei Lebedev <superbobry@gmail.com>
# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
# Contributor: Sylvester Johansson <scj(at)archlinux(dot)us>
-pkgname=ocaml-zip
-pkgver=1.10
+_pkgname=camlzip
+pkgname=ocaml-$_pkgname
_pkgver=rel110
+pkgver=1.10
pkgrel=1
pkgdesc="ZIP and gzip library for OCaml"
arch=('i686' 'x86_64')
@@ -13,12 +14,15 @@ url="https://github.com/xavierleroy/camlzip"
license=('GPL')
depends=('ocaml' 'zlib')
makedepends=('ocaml-findlib')
+provides=('ocaml-zip')
+conflicts=('ocaml-zip')
+replaces=('ocaml-zip')
options=(!strip staticlibs)
-source=("https://github.com/xavierleroy/camlzip/archive/$_pkgver.tar.gz")
+source=("https://github.com/xavierleroy/$_pkgname/archive/$_pkgver.tar.gz")
md5sums=('97efd563735b4b6e7ae463b91aa72405')
build() {
- cd "$srcdir/camlzip-$_pkgver"
+ cd "$srcdir/$_pkgname-$_pkgver"
make all allopt
mkdir -p html
@@ -26,7 +30,7 @@ build() {
}
package() {
- cd "$srcdir/camlzip-$_pkgver"
+ cd "$srcdir/$_pkgname-$_pkgver"
export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
export OCAMLFIND_LDCONF="ignore"