summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-04-21 22:46:07 +0200
committerM0Rf302018-04-21 22:46:07 +0200
commit21c06d9eaca36b7b2908b01022a56af93812abd9 (patch)
treec5fc3a2e3e9a31ac2e03a691c40dd87584016b13
parent99daecf261b863238f22f3a68bc17a0ec1567001 (diff)
downloadaur-21c06d9eaca36b7b2908b01022a56af93812abd9.tar.gz
ocaml-camomile: 1.0.1
-rw-r--r--.SRCINFO15
-rw-r--r--0002-Install-missing-camomileLibrary.a.patch23
-rw-r--r--4.05-typing-fix.patch43
-rw-r--r--PKGBUILD47
4 files changed, 26 insertions, 102 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a38517208ec0..1e36936e6653 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
pkgbase = ocaml-camomile
pkgdesc = Comprehensive Unicode library for OCaml
- pkgver = 0.8.5
- pkgrel = 6
+ pkgver = 1.0.1
+ pkgrel = 1
url = https://github.com/yoriyuki/Camomile
arch = i686
arch = x86_64
license = LGPL
makedepends = ocaml
- makedepends = camlp4
- makedepends = ocaml-findlib>=1.2.3
+ makedepends = dune
options = !strip
options = !makeflags
options = staticlibs
- source = https://github.com/yoriyuki/camomile/releases/download/rel-0.8.5/camomile-0.8.5.tar.bz2
- source = 0002-Install-missing-camomileLibrary.a.patch
- source = 4.05-typing-fix.patch
- sha512sums = ef4da32f955e69e0b2958b4b2bf12ae94e210d8aa7cee5a9030607b79ac43a884758549f3164c223fb07d987a4a50b15f0bc5083ff67120270409f7fb9928014
- sha512sums = d3a802e00ec871fffab8896faffe1592c2e92e6ae33c5226cd8ba371ec8f8632d4079984c2f2238e907c5ebb8ece68d142a42e5071f6660eeeaf5be0bb15d0bd
- sha512sums = 7476ea0bf478c15e94335ac2a669d7e7341144283efff6418dad8f32c5329b54817136892192ffed91904baf52b260990a9d8e2bb0517f09349174b076fc57d5
+ source = https://github.com/yoriyuki/Camomile/archive/1.0.1.tar.gz
+ md5sums = 9557fd86f13eba45474fc1336f225f32
pkgname = ocaml-camomile
diff --git a/0002-Install-missing-camomileLibrary.a.patch b/0002-Install-missing-camomileLibrary.a.patch
deleted file mode 100644
index 23d300d1b38f..000000000000
--- a/0002-Install-missing-camomileLibrary.a.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Stephane Glondu <steph@glondu.net>
-Date: Fri, 29 Jul 2011 19:46:45 +0200
-Subject: Install missing camomileLibrary.a
-
-Signed-off-by: Stephane Glondu <steph@glondu.net>
----
- Makefile.in | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index e1fc579..45dc0ac 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -406,7 +406,7 @@ install-with-ocamlfind:
- files= &&\
- if [ -f camomileLibrary.cmx ]; then files=camomileLibrary.cmx; fi && \
- if [ -f camomileLibrary.cma ]; then files="camomileLibrary.cma $$files"; fi && \
-- if [ -f camomileLibrary.cmxa ]; then files="camomileLibrary.cmxa $$files"; fi && \
-+ if [ -f camomileLibrary.cmxa ]; then files="camomileLibrary.cmxa camomileLibrary.a $$files"; fi && \
- if [ -f camomileLibraryDefault.cmx ]; then files="camomileLibraryDefault.cmx $$files"; fi && \
- if [ -f camomileLibraryDyn.cmx ]; then files="camomileLibraryDyn.cmx $$files"; fi && \
- if [ -f camomile.cma ]; then files="camomile.cma $$files"; fi&& \
---
diff --git a/4.05-typing-fix.patch b/4.05-typing-fix.patch
deleted file mode 100644
index 178e4d19debb..000000000000
--- a/4.05-typing-fix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 0fa0a19f15998e89e4b04150dd74529bbd406f42 Mon Sep 17 00:00:00 2001
-From: Gabriel Scherer <gabriel.scherer@gmail.com>
-Date: Fri, 24 Feb 2017 22:30:23 -0500
-Subject: [PATCH] 4.05 compatibility: use explicit module signatures
-
-In 4.05, checking for non-generalizable inference variable ('_a)
-(forbidden in toplevel modules and functors) happens before checking
-the .ml file against the .mli signature, so non-generalizable
-variables that were previously resolved through the .mli constraint
-are now underspecified and result in a compilation failure
-(see MPR#7414, GPR#929). This commit adds enough annotations to avoid
-such underspecified variables in functors.
----
- internal/unimap.ml | 2 +-
- public/uCharInfo.ml | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/internal/unimap.ml b/internal/unimap.ml
-index b6fdbde..6a7cc30 100644
---- a/internal/unimap.ml
-+++ b/internal/unimap.ml
-@@ -58,7 +58,7 @@ val of_name : string -> t
- end
-
-
--module Make (Config : ConfigInt.Type) = struct
-+module Make (Config : ConfigInt.Type) : Type = struct
-
- type mapping = {no_char : int; tbl : Tbl31.Bytes.t}
-
-diff --git a/public/uCharInfo.ml b/public/uCharInfo.ml
-index 69bf141..6a0337a 100644
---- a/public/uCharInfo.ml
-+++ b/public/uCharInfo.ml
-@@ -298,7 +298,7 @@ val load_composition_exclusion_tbl : unit -> UCharTbl.Bool.t
-
- end
-
--module Make (Config : ConfigInt.Type) = struct
-+module Make (Config : ConfigInt.Type) : Type = struct
- include Unidata.Make(Config)
-
- (* General category *)
diff --git a/PKGBUILD b/PKGBUILD
index 84c5adb4a8e0..f9b5142bfc5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,37 @@
-# Maintainer: Marek Kubica <marek@xivilization.net>
+# Maintainer: robertfoster
+# Contributor: Marek Kubica <marek@xivilization.net>
# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
+
pkgname=ocaml-camomile
-pkgver=0.8.5
-pkgrel=6
+pkgver=1.0.1
+pkgrel=1
pkgdesc="Comprehensive Unicode library for OCaml"
arch=('i686' 'x86_64')
url="https://github.com/yoriyuki/Camomile"
license=('LGPL')
-makedepends=('ocaml' 'camlp4' 'ocaml-findlib>=1.2.3')
-source=(https://github.com/yoriyuki/${pkgname/ocaml-}/releases/download/rel-$pkgver/${pkgname/ocaml-/}-$pkgver.tar.bz2
- 0002-Install-missing-camomileLibrary.a.patch
- 4.05-typing-fix.patch)
-sha512sums=('ef4da32f955e69e0b2958b4b2bf12ae94e210d8aa7cee5a9030607b79ac43a884758549f3164c223fb07d987a4a50b15f0bc5083ff67120270409f7fb9928014'
- 'd3a802e00ec871fffab8896faffe1592c2e92e6ae33c5226cd8ba371ec8f8632d4079984c2f2238e907c5ebb8ece68d142a42e5071f6660eeeaf5be0bb15d0bd'
- '7476ea0bf478c15e94335ac2a669d7e7341144283efff6418dad8f32c5329b54817136892192ffed91904baf52b260990a9d8e2bb0517f09349174b076fc57d5')
+makedepends=('ocaml' 'dune')
+source=(https://github.com/yoriyuki/Camomile/archive/$pkgver.tar.gz)
options=(!strip !makeflags staticlibs)
-prepare() {
- cd "${srcdir}/${pkgname/ocaml-/}-${pkgver}"
- # Patch from Debian, Slackware to add camomileLibrary.a which is required
- # for some code to build
- patch -Np1 -i ../0002-Install-missing-camomileLibrary.a.patch
- patch -Np1 -i ../4.05-typing-fix.patch
-}
-
build() {
- cd "${srcdir}/${pkgname/ocaml-/}-${pkgver}"
+ cd Camomile-${pkgver}
+ make all
+}
- ./configure --prefix=/usr
- sed -i -e 's|ocamlfind install|ocamlfind install -destdir '${pkgdir}$(ocamlfind printconf destdir)'|' Makefile
- make
+check() {
+ cd Camomile-${pkgver}
+ make test
}
package() {
- cd "${srcdir}/${pkgname/ocaml-/}-${pkgver}"
+ cd Camomile-${pkgver}
+
+ # Initialize OPAM, this should be removed once opam is “removed” from dune
+ export OPAMROOT="${srcdir}"/opam
+ opam init -n
- mkdir -p "${pkgdir}$(ocamlfind printconf destdir)"
- make DATADIR="${pkgdir}/usr/share" install
- install -Dm 644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ # Work around the install command
+ make OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)" install
}
+md5sums=('9557fd86f13eba45474fc1336f225f32')