summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Kubica2017-08-14 19:15:56 +0200
committerMarek Kubica2017-08-14 19:16:29 +0200
commit99daecf261b863238f22f3a68bc17a0ec1567001 (patch)
treec3241ba2a5af46294108f4e2b2884a1e1ee2de68
parentd0d9c11f2f7cd41ff9b680647edb3d8bbaefbd25 (diff)
downloadaur-99daecf261b863238f22f3a68bc17a0ec1567001.tar.gz
Fix compilation by copying patch from OPAM
-rw-r--r--.SRCINFO4
-rw-r--r--4.05-typing-fix.patch43
-rw-r--r--PKGBUILD9
3 files changed, 52 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4f9387dd59f..a38517208ec0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-camomile
pkgdesc = Comprehensive Unicode library for OCaml
pkgver = 0.8.5
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/yoriyuki/Camomile
arch = i686
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = ocaml-camomile
options = staticlibs
source = https://github.com/yoriyuki/camomile/releases/download/rel-0.8.5/camomile-0.8.5.tar.bz2
source = 0002-Install-missing-camomileLibrary.a.patch
+ source = 4.05-typing-fix.patch
sha512sums = ef4da32f955e69e0b2958b4b2bf12ae94e210d8aa7cee5a9030607b79ac43a884758549f3164c223fb07d987a4a50b15f0bc5083ff67120270409f7fb9928014
sha512sums = d3a802e00ec871fffab8896faffe1592c2e92e6ae33c5226cd8ba371ec8f8632d4079984c2f2238e907c5ebb8ece68d142a42e5071f6660eeeaf5be0bb15d0bd
+ sha512sums = 7476ea0bf478c15e94335ac2a669d7e7341144283efff6418dad8f32c5329b54817136892192ffed91904baf52b260990a9d8e2bb0517f09349174b076fc57d5
pkgname = ocaml-camomile
diff --git a/4.05-typing-fix.patch b/4.05-typing-fix.patch
new file mode 100644
index 000000000000..178e4d19debb
--- /dev/null
+++ b/4.05-typing-fix.patch
@@ -0,0 +1,43 @@
+From 0fa0a19f15998e89e4b04150dd74529bbd406f42 Mon Sep 17 00:00:00 2001
+From: Gabriel Scherer <gabriel.scherer@gmail.com>
+Date: Fri, 24 Feb 2017 22:30:23 -0500
+Subject: [PATCH] 4.05 compatibility: use explicit module signatures
+
+In 4.05, checking for non-generalizable inference variable ('_a)
+(forbidden in toplevel modules and functors) happens before checking
+the .ml file against the .mli signature, so non-generalizable
+variables that were previously resolved through the .mli constraint
+are now underspecified and result in a compilation failure
+(see MPR#7414, GPR#929). This commit adds enough annotations to avoid
+such underspecified variables in functors.
+---
+ internal/unimap.ml | 2 +-
+ public/uCharInfo.ml | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/internal/unimap.ml b/internal/unimap.ml
+index b6fdbde..6a7cc30 100644
+--- a/internal/unimap.ml
++++ b/internal/unimap.ml
+@@ -58,7 +58,7 @@ val of_name : string -> t
+ end
+
+
+-module Make (Config : ConfigInt.Type) = struct
++module Make (Config : ConfigInt.Type) : Type = struct
+
+ type mapping = {no_char : int; tbl : Tbl31.Bytes.t}
+
+diff --git a/public/uCharInfo.ml b/public/uCharInfo.ml
+index 69bf141..6a0337a 100644
+--- a/public/uCharInfo.ml
++++ b/public/uCharInfo.ml
+@@ -298,7 +298,7 @@ val load_composition_exclusion_tbl : unit -> UCharTbl.Bool.t
+
+ end
+
+-module Make (Config : ConfigInt.Type) = struct
++module Make (Config : ConfigInt.Type) : Type = struct
+ include Unidata.Make(Config)
+
+ (* General category *)
diff --git a/PKGBUILD b/PKGBUILD
index 9a816b183056..84c5adb4a8e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,18 @@
# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
pkgname=ocaml-camomile
pkgver=0.8.5
-pkgrel=5
+pkgrel=6
pkgdesc="Comprehensive Unicode library for OCaml"
arch=('i686' 'x86_64')
url="https://github.com/yoriyuki/Camomile"
license=('LGPL')
makedepends=('ocaml' 'camlp4' 'ocaml-findlib>=1.2.3')
source=(https://github.com/yoriyuki/${pkgname/ocaml-}/releases/download/rel-$pkgver/${pkgname/ocaml-/}-$pkgver.tar.bz2
- 0002-Install-missing-camomileLibrary.a.patch)
+ 0002-Install-missing-camomileLibrary.a.patch
+ 4.05-typing-fix.patch)
sha512sums=('ef4da32f955e69e0b2958b4b2bf12ae94e210d8aa7cee5a9030607b79ac43a884758549f3164c223fb07d987a4a50b15f0bc5083ff67120270409f7fb9928014'
- 'd3a802e00ec871fffab8896faffe1592c2e92e6ae33c5226cd8ba371ec8f8632d4079984c2f2238e907c5ebb8ece68d142a42e5071f6660eeeaf5be0bb15d0bd')
+ 'd3a802e00ec871fffab8896faffe1592c2e92e6ae33c5226cd8ba371ec8f8632d4079984c2f2238e907c5ebb8ece68d142a42e5071f6660eeeaf5be0bb15d0bd'
+ '7476ea0bf478c15e94335ac2a669d7e7341144283efff6418dad8f32c5329b54817136892192ffed91904baf52b260990a9d8e2bb0517f09349174b076fc57d5')
options=(!strip !makeflags staticlibs)
prepare() {
@@ -19,6 +21,7 @@ prepare() {
# Patch from Debian, Slackware to add camomileLibrary.a which is required
# for some code to build
patch -Np1 -i ../0002-Install-missing-camomileLibrary.a.patch
+ patch -Np1 -i ../4.05-typing-fix.patch
}
build() {