summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author404DeadLink2022-11-04 12:56:41 +0100
committer404DeadLink2022-11-04 12:56:41 +0100
commitc79bb7cacd1724e93bf4e8a34709ea0495223d88 (patch)
tree1cd6942aecf82dff2ff2b58ab46aff7f2157fa75
downloadaur-c79bb7cacd1724e93bf4e8a34709ea0495223d88.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19a69eb9f7e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ocaml-cil-git
+ pkgdesc = C Intermediate Language CIL is a front-end for the C programming language that facilitates program analysis and transformation. CIL will parse and typecheck a program, and compile it into a simplified subset of C.
+ pkgver = r4768.673aa00b
+ pkgrel = 1
+ url = https://goblint.github.io/cil/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = lib32-glibc
+ makedepends = dune
+ makedepends = perl
+ makedepends = cppo
+ depends = ocaml
+ depends = ocaml-zarith
+ depends = ocaml-stdlib-shims
+ depends = ocaml-ppx_deriving_yojson-git
+ provides = ocaml-cil
+ conflicts = ocaml-cil
+ options = !strip
+ source = ocaml-cil::git+https://github.com/goblint/cil
+ md5sums = SKIP
+
+pkgname = ocaml-cil-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ca771413b7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: 404DeadLink <msg on AUR>
+pkgname=ocaml-cil-git
+pkgver=r4768.673aa00b
+pkgrel=1
+pkgdesc="C Intermediate Language
+CIL is a front-end for the C programming language that facilitates program analysis and transformation. CIL will parse and typecheck a program, and compile it into a simplified subset of C.
+"
+arch=('x86_64')
+url="https://goblint.github.io/cil/"
+license=('GPL')
+groups=()
+depends=('ocaml' 'ocaml-zarith' 'ocaml-stdlib-shims' 'ocaml-ppx_deriving_yojson-git')
+makedepends=('git' 'lib32-glibc' 'dune' 'perl' 'cppo')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=(!strip)
+install=
+source=("${pkgname%-git}::git+https://github.com/goblint/cil")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ dune build @install
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ dune runtest
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="/usr/lib/ocaml"
+
+ # Dune installs documentation in /usr/doc, fix that.
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}