summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-10-07 11:33:36 +0200
committerDaniel Peukert2023-10-07 11:33:36 +0200
commitf12033da8ef05becf8e598526def1db63b32ba56 (patch)
treecaca79ecae3e9d9449f1d64712d57b2b33707203
parenta918dfc76cfb42fe8bc6c793b7b468d78e8e7c57 (diff)
downloadaur-f12033da8ef05becf8e598526def1db63b32ba56.tar.gz
Update ocaml-core to 0.16.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7510e8a94cd0..1c6218c48c28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-core
pkgdesc = Industrial strength alternative to OCaml's standard library
- pkgver = 0.16.1
+ pkgver = 0.16.2
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/core
@@ -31,7 +31,7 @@ pkgbase = ocaml-core
depends = ocaml-typerep>=0.16.0
depends = ocaml-variantslib>=0.16.0
options = !strip
- source = ocaml-core-0.16.1.tar.gz::https://github.com/janestreet/core/archive/v0.16.1.tar.gz
- sha512sums = 5f9f4400b6e42b74ffd57223cb67884368d324739565bbb20162547ede8bd6d0ece3cc265503b674829f9cf373784e8036d4c73e26e9196aa5446de69b63e181
+ source = ocaml-core-0.16.2.tar.gz::https://github.com/janestreet/core/archive/v0.16.2.tar.gz
+ sha512sums = 2e68556773549e0bf302c8733c9fc57df3c0fd73a1b547dc17097f74c5b5482c816ef89853b437e49452da7c124ef32a8a0de0dff64d71145b2ab11befbe5bb2
pkgname = ocaml-core
diff --git a/PKGBUILD b/PKGBUILD
index 51c10326f33a..568f29cf2c5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,10 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='core'
pkgname="ocaml-$_projectname"
-pkgver='0.16.1'
+pkgver='0.16.2'
pkgrel='1'
epoch='1'
pkgdesc="Industrial strength alternative to OCaml's standard library"
-# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
@@ -14,7 +13,7 @@ depends=('ocaml>=4.14.0' 'ocaml-base>=0.16.0' 'ocaml-base_bigstring>=0.16.0' 'oc
makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('5f9f4400b6e42b74ffd57223cb67884368d324739565bbb20162547ede8bd6d0ece3cc265503b674829f9cf373784e8036d4c73e26e9196aa5446de69b63e181')
+sha512sums=('2e68556773549e0bf302c8733c9fc57df3c0fd73a1b547dc17097f74c5b5482c816ef89853b437e49452da7c124ef32a8a0de0dff64d71145b2ab11befbe5bb2')
_sourcedirectory="$_projectname-$pkgver"
@@ -27,6 +26,10 @@ package() {
cd "$srcdir/$_sourcedirectory/"
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
+ for _folder in "$pkgdir/usr/share/doc/"*; do
+ mv "$_folder" "$pkgdir/usr/share/doc/ocaml-$(basename "$_folder")"
+ done
+
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}