summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2016-02-06 04:32:12 +0100
committerJ5lx2016-02-06 04:32:12 +0100
commit3ddf2419d5f52a622676b9c65d59592bf8a777d1 (patch)
tree1d655bdcdee0e9b2518226c6e3535639bfd06357
parent64d29ba22afe970313bef1d0eee7bebb269eac70 (diff)
downloadaur-3ddf2419d5f52a622676b9c65d59592bf8a777d1.tar.gz
113.24.00-1: New version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD20
-rw-r--r--libdir.patch36
3 files changed, 62 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8beac6edc806..7eedfdd6b3e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 03:31:52 UTC 2016
pkgbase = ocaml-core_kernel
pkgdesc = Industrial strength alternative to OCaml's standard library (system-independent part)
- pkgver = 113.00.00
+ pkgver = 113.24.00
pkgrel = 1
url = https://github.com/janestreet/core_kernel
arch = i686
@@ -9,22 +11,21 @@ pkgbase = ocaml-core_kernel
makedepends = ocaml-findlib
depends = ocaml
depends = ocaml-bin_prot
- depends = camlp4
- depends = ocaml-comparelib
- depends = ocaml-custom_printf
- depends = ocaml-enumerate
depends = ocaml-fieldslib
- depends = ocaml-herelib
- depends = ocaml-pa_bench
- depends = ocaml-pa_ounit
- depends = ocaml-pa_test
- depends = ocaml-pipebang
+ depends = ocaml-ppx_assert
+ depends = ocaml-ppx_bench
+ depends = ocaml-ppx_driver
+ depends = ocaml-ppx_expect
+ depends = ocaml-ppx_inline_test
+ depends = ocaml-ppx_jane
depends = ocaml-sexplib
depends = ocaml-typerep
depends = ocaml-variantslib
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.00/files/core_kernel-113.00.00.tar.gz
- md5sums = 326568be2d9ff48a34bce19fc562ee90
+ source = https://ocaml.janestreet.com/ocaml-core/113.24/files/core_kernel-113.24.00.tar.gz
+ source = libdir.patch
+ md5sums = 4bf982ebd3c944149b2032a10226f8c2
+ md5sums = 7f0a951f1ac87385272ea7a6dd58762a
pkgname = ocaml-core_kernel
diff --git a/PKGBUILD b/PKGBUILD
index a5dd2fa88059..5f7b1e3fdc16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-core_kernel
-pkgver=113.00.00
+pkgver=113.24.00
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Industrial strength alternative to OCaml's standard library (system-independent part)"
url="https://github.com/janestreet/core_kernel"
-depends=('ocaml' 'ocaml-bin_prot' 'camlp4' 'ocaml-comparelib' 'ocaml-custom_printf' 'ocaml-enumerate' 'ocaml-fieldslib' 'ocaml-herelib' 'ocaml-pa_bench' 'ocaml-pa_ounit' 'ocaml-pa_test' 'ocaml-pipebang' 'ocaml-sexplib' 'ocaml-typerep' 'ocaml-variantslib')
+depends=('ocaml' 'ocaml-bin_prot' 'ocaml-fieldslib' 'ocaml-ppx_assert' 'ocaml-ppx_bench' 'ocaml-ppx_driver' 'ocaml-ppx_expect' 'ocaml-ppx_inline_test' 'ocaml-ppx_jane' 'ocaml-sexplib' 'ocaml-typerep' 'ocaml-variantslib')
makedepends=('ocaml-findlib')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz"
+ "libdir.patch")
options=('!strip')
-md5sums=('326568be2d9ff48a34bce19fc562ee90')
+md5sums=('4bf982ebd3c944149b2032a10226f8c2'
+ '7f0a951f1ac87385272ea7a6dd58762a')
+
+prepare() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ patch -Np1 < "${srcdir}/libdir.patch"
+}
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
@@ -23,7 +31,5 @@ build() {
package() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p $OCAMLFIND_DESTDIR/stublibs
- make install
+ make install LIBDIR="${pkgdir}$(ocamlc -where)"
}
diff --git a/libdir.patch b/libdir.patch
new file mode 100644
index 000000000000..6284fcd558b0
--- /dev/null
+++ b/libdir.patch
@@ -0,0 +1,36 @@
+diff -aur package.pristine/Makefile package.new/Makefile
+--- package.pristine/Makefile 2016-02-06 01:55:14.650150309 +0100
++++ package.new/Makefile 2016-02-06 01:57:56.012174364 +0100
+@@ -29,26 +29,26 @@
+ ocaml -I js-utils js-utils/gen_install.ml
+
+ install: $(NAME).install
+- opam-installer -i --prefix $(PREFIX) $(NAME).install
++ opam-installer -i --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
+
+ uninstall: $(NAME).install
+- opam-installer -u --prefix $(PREFIX) $(NAME).install
++ opam-installer -u --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
+
+ reinstall: $(NAME).install
+- opam-installer -u --prefix $(PREFIX) $(NAME).install &> /dev/null || true
+- opam-installer -i --prefix $(PREFIX) $(NAME).install
++ opam-installer -u --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install &> /dev/null || true
++ opam-installer -i --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
+
+ bin.tar.gz: $(NAME).install
+ rm -rf _install
+ mkdir _install
+- opam-installer -i --prefix _install $(NAME).install
++ opam-installer -i --prefix _install --libdir $(LIBDIR) $(NAME).install
+ tar czf bin.tar.gz -C _install .
+ rm -rf _install
+
+ bin.lzo: $(NAME).install
+ rm -rf _install
+ mkdir _install
+- opam-installer -i --prefix _install $(NAME).install
++ opam-installer -i --prefix _install --libdir $(LIBDIR) $(NAME).install
+ cd _install && lzop -1 -P -o ../bin.lzo `find . -type f`
+ rm -rf _install
+