summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-08-18 13:19:25 +0200
committerDaniel Peukert2021-08-18 13:19:25 +0200
commit95a7724ef39853f5fd1c0a697d8179b478556733 (patch)
tree940dbd74eafc6f36a4a2020f16a68a915fb2af7a
parentca6350e04bed8252e27812651839ba44a2ecc22b (diff)
downloadaur-95a7724ef39853f5fd1c0a697d8179b478556733.tar.gz
Update ocaml-core_kernel to 0.14.2, ocaml-ppx_optcomp to 0.14.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 816df0bcfbed..7f7fbcb88d8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-core_kernel
pkgdesc = Industrial strength alternative to OCaml's standard library (system-independent part)
- pkgver = 0.14.1
- pkgrel = 2
+ pkgver = 0.14.2
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/core_kernel
arch = x86_64
@@ -25,6 +25,7 @@ pkgbase = ocaml-core_kernel
depends = ocaml-ppx_hash>=0.14.0
depends = ocaml-ppx_inline_test>=0.14.0
depends = ocaml-ppx_jane>=0.14.0
+ depends = ocaml-ppx_optcomp>=0.14.3
depends = ocaml-ppx_sexp_conv>=0.14.0
depends = ocaml-ppx_sexp_message>=0.14.0
depends = ocaml-sexplib>=0.14.0
@@ -34,7 +35,7 @@ pkgbase = ocaml-core_kernel
depends = ocaml-typerep>=0.14.0
depends = ocaml-variantslib>=0.14.0
options = !strip
- source = ocaml-core_kernel-1:0.14.1-2.tar.gz::https://github.com/janestreet/core_kernel/archive/v0.14.1.tar.gz
- sha256sums = 1d91a0d58e9a98809eb3bc888ae716e786c68ad5d07a874c37d9c1ef9fd24438
+ source = ocaml-core_kernel-1:0.14.2-1.tar.gz::https://github.com/janestreet/core_kernel/archive/v0.14.2.tar.gz
+ sha256sums = 66f5353964d35a994ec7fdc88fe60ae5d497ac89a8042786f3e37d9e2202ce4b
pkgname = ocaml-core_kernel
diff --git a/PKGBUILD b/PKGBUILD
index 982a64fd56b7..5429f3060dc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='core_kernel'
pkgname="ocaml-$_projectname"
-pkgver='0.14.1'
-pkgrel='2'
+pkgver='0.14.2'
+pkgrel='1'
epoch='1'
pkgdesc="Industrial strength alternative to OCaml's standard library (system-independent part)"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.08.0' 'ocaml-base>=0.14.0' 'ocaml-base_bigstring>=0.14.0' 'ocaml-base_quickcheck>=0.14.0' 'ocaml-bin_prot>=0.14.0' 'ocaml-fieldslib>=0.14.0' 'ocaml-jane-street-headers>=0.14.0' 'ocaml-jst-config>=0.14.0' 'ocaml-ppx_assert>=0.14.0' 'ocaml-ppx_base>=0.14.0' 'ocaml-ppx_hash>=0.14.0' 'ocaml-ppx_inline_test>=0.14.0' 'ocaml-ppx_jane>=0.14.0' 'ocaml-ppx_sexp_conv>=0.14.0' 'ocaml-ppx_sexp_message>=0.14.0' 'ocaml-sexplib>=0.14.0' 'ocaml-splittable_random>=0.14.0' 'ocaml-stdio>=0.14.0' 'ocaml-time_now>=0.14.0' 'ocaml-typerep>=0.14.0' 'ocaml-variantslib>=0.14.0')
+depends=('ocaml>=4.08.0' 'ocaml-base>=0.14.0' 'ocaml-base_bigstring>=0.14.0' 'ocaml-base_quickcheck>=0.14.0' 'ocaml-bin_prot>=0.14.0' 'ocaml-fieldslib>=0.14.0' 'ocaml-jane-street-headers>=0.14.0' 'ocaml-jst-config>=0.14.0' 'ocaml-ppx_assert>=0.14.0' 'ocaml-ppx_base>=0.14.0' 'ocaml-ppx_hash>=0.14.0' 'ocaml-ppx_inline_test>=0.14.0' 'ocaml-ppx_jane>=0.14.0' 'ocaml-ppx_optcomp>=0.14.3' 'ocaml-ppx_sexp_conv>=0.14.0' 'ocaml-ppx_sexp_message>=0.14.0' 'ocaml-sexplib>=0.14.0' 'ocaml-splittable_random>=0.14.0' 'ocaml-stdio>=0.14.0' 'ocaml-time_now>=0.14.0' 'ocaml-typerep>=0.14.0' 'ocaml-variantslib>=0.14.0')
makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('1d91a0d58e9a98809eb3bc888ae716e786c68ad5d07a874c37d9c1ef9fd24438')
+sha256sums=('66f5353964d35a994ec7fdc88fe60ae5d497ac89a8042786f3e37d9e2202ce4b')
_sourcedirectory="$_projectname-$pkgver"