summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-06-14 20:31:42 +0200
committerDaniel Peukert2022-06-14 20:31:42 +0200
commitdf6fb325da7a77dc1dc72b5e41afe5ce27ae7c35 (patch)
tree499f4bc7432180faf17f669c3f8feb24e20b2cf7
parent41413579d0e158946ab0e7dee9a80035fcfa58bc (diff)
downloadaur-df6fb325da7a77dc1dc72b5e41afe5ce27ae7c35.tar.gz
Fix dun calls, sha256 -> sha512
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd737ebe4429..66cef5b687af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-dtoa
pkgdesc = double-to-ascii ocaml implementation
pkgver = 0.3.2
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/flowtype/ocaml-dtoa
arch = x86_64
arch = i686
@@ -14,11 +14,11 @@ pkgbase = ocaml-dtoa
makedepends = dune>=1.0.0
depends = ocaml>=4.01.0
options = !strip
- source = ocaml-dtoa-0.3.2-6.tar.gz::https://github.com/flowtype/ocaml-dtoa/archive/v0.3.2.tar.gz
+ source = ocaml-dtoa-0.3.2-7.tar.gz::https://github.com/flowtype/ocaml-dtoa/archive/v0.3.2.tar.gz
source = fix-ounit-name.diff
source = fix-tests.diff
- sha256sums = 967bdcf83f67491a27a3e0c31bb55696f4f89a00be9aa0b3a248c7ef14374afd
- sha256sums = 9b26ee783aeba8c8a2f299e2fd061d06ebceac61cbe13becd2debb93b61aa4e4
- sha256sums = fc4ab96c8be38e7a2440ad80b474631829d48ae4a25c16a886997304d44da4b1
+ sha512sums = a5dcce83f53725c45b0891f6af6275c5e617d536a2d491852215c9aefbbd22c7ac65f2738795eaba3a162e360d2fa86b33a98cdefb030230045789179c300604
+ sha512sums = a2a35245f4d50db7d6c81bd8a2f94021a11493e40c7caae2a78e5ac989dbd99e6bc1cfa885ecf49161aab67eca9666c0370bb9dfb0df5905e85b463beefc5f79
+ sha512sums = eb52bd485c41458c782227e88a649083aeef3e3372de1c5240237da5f25075d4cc98a8ff18bda1e9a2ee2e4d9d3c3509e80c34dce0426bc61992410cb438f271
pkgname = ocaml-dtoa
diff --git a/PKGBUILD b/PKGBUILD
index 5cadffa0cabc..86058c3160ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_projectname='dtoa'
pkgname="ocaml-$_projectname"
pkgver='0.3.2'
-pkgrel='6'
+pkgrel='7'
pkgdesc='double-to-ascii ocaml implementation'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/flowtype/$pkgname"
@@ -16,9 +16,9 @@ source=(
'fix-ounit-name.diff'
'fix-tests.diff'
)
-sha256sums=('967bdcf83f67491a27a3e0c31bb55696f4f89a00be9aa0b3a248c7ef14374afd'
- '9b26ee783aeba8c8a2f299e2fd061d06ebceac61cbe13becd2debb93b61aa4e4'
- 'fc4ab96c8be38e7a2440ad80b474631829d48ae4a25c16a886997304d44da4b1')
+sha512sums=('a5dcce83f53725c45b0891f6af6275c5e617d536a2d491852215c9aefbbd22c7ac65f2738795eaba3a162e360d2fa86b33a98cdefb030230045789179c300604'
+ 'a2a35245f4d50db7d6c81bd8a2f94021a11493e40c7caae2a78e5ac989dbd99e6bc1cfa885ecf49161aab67eca9666c0370bb9dfb0df5905e85b463beefc5f79'
+ 'eb52bd485c41458c782227e88a649083aeef3e3372de1c5240237da5f25075d4cc98a8ff18bda1e9a2ee2e4d9d3c3509e80c34dce0426bc61992410cb438f271')
_sourcedirectory="$pkgname-$pkgver"
@@ -30,21 +30,17 @@ prepare() {
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
check() {
cd "$srcdir/$_sourcedirectory/"
- dune runtest -p "$_projectname" --verbose
+ dune runtest --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
-
- install -dm755 "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
- rm -r "$pkgdir/usr/doc/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"