summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-02-26 10:47:49 +0100
committerDaniel Peukert2023-02-26 10:47:49 +0100
commitff5b8e165f04250e55c20da1b42d68152803126a (patch)
tree81fdb7bd0b9359dd509b46f484d018825ea3e583
parent07d56cf8f5a12c62dd69a5499f7c33c020fe1ef7 (diff)
downloadaur-ff5b8e165f04250e55c20da1b42d68152803126a.tar.gz
Update ocaml-dtoa to 0.3.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--fix-ounit-name.diff12
-rw-r--r--fix-tests.diff51
4 files changed, 12 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb6831b70d54..7991160b8772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ocaml-dtoa
pkgdesc = double-to-ascii ocaml implementation
- pkgver = 0.3.2
- pkgrel = 8
- url = https://github.com/flowtype/ocaml-dtoa
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://github.com/flow/ocaml-dtoa
arch = x86_64
arch = i686
arch = arm
@@ -11,14 +11,10 @@ pkgbase = ocaml-dtoa
arch = aarch64
license = MIT
checkdepends = ocaml-ounit>=2.0.0
- makedepends = dune>=1.0.0
+ makedepends = dune>=2.0.0
depends = ocaml>=4.01.0
options = !strip
- source = ocaml-dtoa-0.3.2-8.tar.gz::https://github.com/flowtype/ocaml-dtoa/archive/v0.3.2.tar.gz
- source = fix-ounit-name.diff
- source = fix-tests.diff
- sha512sums = a5dcce83f53725c45b0891f6af6275c5e617d536a2d491852215c9aefbbd22c7ac65f2738795eaba3a162e360d2fa86b33a98cdefb030230045789179c300604
- sha512sums = a2a35245f4d50db7d6c81bd8a2f94021a11493e40c7caae2a78e5ac989dbd99e6bc1cfa885ecf49161aab67eca9666c0370bb9dfb0df5905e85b463beefc5f79
- sha512sums = eb52bd485c41458c782227e88a649083aeef3e3372de1c5240237da5f25075d4cc98a8ff18bda1e9a2ee2e4d9d3c3509e80c34dce0426bc61992410cb438f271
+ source = ocaml-dtoa-0.3.3-1.tar.gz::https://github.com/flow/ocaml-dtoa/archive/v0.3.3.tar.gz
+ sha512sums = f5d9a287637c7a32c48ad2bbb0d7420c1b59fca26e2569b234d8f0e7b2d6b99d3f3cf0f2755e50d51c7453422593c2be6a54a90f49dfd672622c04f52c92359e
pkgname = ocaml-dtoa
diff --git a/PKGBUILD b/PKGBUILD
index 4e00fe5f3947..9a1c255118f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,21 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='dtoa'
pkgname="ocaml-$_projectname"
-pkgver='0.3.2'
-pkgrel='8'
+pkgver='0.3.3'
+pkgrel='1'
pkgdesc='double-to-ascii ocaml implementation'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/flowtype/$pkgname"
+url="https://github.com/flow/$pkgname"
license=('MIT')
depends=('ocaml>=4.01.0')
-makedepends=('dune>=1.0.0')
+makedepends=('dune>=2.0.0')
checkdepends=('ocaml-ounit>=2.0.0')
options=('!strip')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz"
- 'fix-ounit-name.diff'
- 'fix-tests.diff'
-)
-sha512sums=('a5dcce83f53725c45b0891f6af6275c5e617d536a2d491852215c9aefbbd22c7ac65f2738795eaba3a162e360d2fa86b33a98cdefb030230045789179c300604'
- 'a2a35245f4d50db7d6c81bd8a2f94021a11493e40c7caae2a78e5ac989dbd99e6bc1cfa885ecf49161aab67eca9666c0370bb9dfb0df5905e85b463beefc5f79'
- 'eb52bd485c41458c782227e88a649083aeef3e3372de1c5240237da5f25075d4cc98a8ff18bda1e9a2ee2e4d9d3c3509e80c34dce0426bc61992410cb438f271')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('f5d9a287637c7a32c48ad2bbb0d7420c1b59fca26e2569b234d8f0e7b2d6b99d3f3cf0f2755e50d51c7453422593c2be6a54a90f49dfd672622c04f52c92359e')
_sourcedirectory="$pkgname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- patch --forward -p1 < "$srcdir/fix-ounit-name.diff"
- patch --forward -p1 < "$srcdir/fix-tests.diff"
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose
diff --git a/fix-ounit-name.diff b/fix-ounit-name.diff
deleted file mode 100644
index 5233a48ad750..000000000000
--- a/fix-ounit-name.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/test/dune b/test/dune
-index 6a4b3b9..64327be 100644
---- a/test/dune
-+++ b/test/dune
-@@ -1,6 +1,6 @@
- (executable
- (name test)
-- (libraries dtoa oUnit))
-+ (libraries dtoa ounit2))
-
- (alias
- (name runtest)
diff --git a/fix-tests.diff b/fix-tests.diff
deleted file mode 100644
index 045e6c0ade42..000000000000
--- a/fix-tests.diff
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/test/ecma_test.ml b/test/ecma_test.ml
-index 7e27652..de62c95 100644
---- a/test/ecma_test.ml
-+++ b/test/ecma_test.ml
-@@ -50,9 +50,9 @@ let tests = "ecma_string_of_float" >::: [
-
- eq "5e-324" (ecma_string_of_float 5e-324);
- eq "1.7976931348623157e+308" (ecma_string_of_float 1.7976931348623157e308);
-- eq "NaN" (ecma_string_of_float Pervasives.nan);
-- eq "Infinity" (ecma_string_of_float Pervasives.infinity);
-- eq "-Infinity" (ecma_string_of_float Pervasives.neg_infinity);
-+ eq "NaN" (ecma_string_of_float Stdlib.nan);
-+ eq "Infinity" (ecma_string_of_float Stdlib.infinity);
-+ eq "-Infinity" (ecma_string_of_float Stdlib.neg_infinity);
-
- (* grisu3 fails, uses bignum *)
- eq "0.000035689" (ecma_string_of_float 0.000035689);
-diff --git a/test/g_fmt_test.ml b/test/g_fmt_test.ml
-index 9d0ae95..201377c 100644
---- a/test/g_fmt_test.ml
-+++ b/test/g_fmt_test.ml
-@@ -49,9 +49,9 @@ let tests = "g_fmt" >::: [
-
- eq "5e-324" (g_fmt 5e-324);
- eq "1.7976931348623157e+308" (g_fmt 1.7976931348623157e308);
-- eq "NaN" (g_fmt Pervasives.nan);
-- eq "Infinity" (g_fmt Pervasives.infinity);
-- eq "-Infinity" (g_fmt Pervasives.neg_infinity);
-+ eq "NaN" (g_fmt Stdlib.nan);
-+ eq "Infinity" (g_fmt Stdlib.infinity);
-+ eq "-Infinity" (g_fmt Stdlib.neg_infinity);
-
- (* grisu3 fails, uses bignum *)
- eq "3.5689e-5" (g_fmt 0.000035689);
-diff --git a/test/shortest_test.ml b/test/shortest_test.ml
-index 0c7226a..2071bb0 100644
---- a/test/shortest_test.ml
-+++ b/test/shortest_test.ml
-@@ -53,9 +53,9 @@ let tests = "shortest_string_of_float" >::: [
-
- eq "5e-324" (shortest_string_of_float 5e-324);
- eq "17976931348623157e292" (shortest_string_of_float 1.7976931348623157e308);
-- eq "NaN" (shortest_string_of_float Pervasives.nan);
-- eq "Infinity" (shortest_string_of_float Pervasives.infinity);
-- eq "-Infinity" (shortest_string_of_float Pervasives.neg_infinity);
-+ eq "NaN" (shortest_string_of_float Stdlib.nan);
-+ eq "Infinity" (shortest_string_of_float Stdlib.infinity);
-+ eq "-Infinity" (shortest_string_of_float Stdlib.neg_infinity);
-
- (* grisu3 fails, uses bignum *)
- eq "35689e-9" (shortest_string_of_float 0.000035689);