summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 15:09:02 +0200
committerJ5lx2015-10-10 15:09:02 +0200
commita050f3d8fc9b6a0bf07c5484488f665db5ccf8e0 (patch)
tree4b270789eef282e4283a997f308debe3768a36aa
downloadaur-a050f3d8fc9b6a0bf07c5484488f665db5ccf8e0.tar.gz
0.3.2-1: Initial package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..217f16adafa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ocaml-dtools
+ pkgdesc = OCaml modules for writing daemons
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-dtools
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = ocaml-findlib
+ depends = ocaml
+ options = !strip
+ source = https://github.com/savonet/ocaml-dtools/releases/download/0.3.2/ocaml-dtools-0.3.2.tar.gz
+ md5sums = 804d89075e50f4db71cbd7d6f3c100e1
+
+pkgname = ocaml-dtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e81495a7ebe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-dtools
+pkgver=0.3.2
+pkgrel=1
+license=('GPL2')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml modules for writing daemons")
+url="https://github.com/savonet/ocaml-dtools"
+depends=('ocaml')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-dtools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('804d89075e50f4db71cbd7d6f3c100e1')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+ make install
+}