summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-12-15 00:06:23 +0100
committerM0Rf302019-12-15 00:06:23 +0100
commit179ebe8d1e629a68a0ab409c7872fcc2872bdd0a (patch)
tree4530257538e55f6eac818ee7a09dd30df0b75eb0
downloadaur-179ebe8d1e629a68a0ab409c7872fcc2872bdd0a.tar.gz
ocaml-dtools-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af389d2a9521
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-dtools-git
+ pkgdesc = OCaml modules for writing daemons
+ pkgver = r100.c9df99e
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-dtools
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-syslog
+ options = !strip
+ source = ocaml-dtools-git::git+https://github.com/savonet/ocaml-dtools
+ md5sums = SKIP
+
+pkgname = ocaml-dtools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd34bbfaeef7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: robertfoster
+pkgname=ocaml-dtools-git
+pkgver=r100.c9df99e
+pkgrel=1
+pkgdesc="OCaml modules for writing daemons"
+arch=('i686' 'x86_64')
+url="https://github.com/savonet/ocaml-dtools"
+license=('GPL2')
+depends=('ocaml' 'ocaml-syslog')
+makedepends=('ocaml-findlib')
+options=('!strip')
+source=("$pkgname::git+https://github.com/savonet/ocaml-dtools")
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./bootstrap
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+ make install
+}
+md5sums=('SKIP')