summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 15:15:35 +0200
committerJ5lx2015-10-10 15:15:35 +0200
commit7bc03e7922fd6a8be2204f6d2ca94a82dafac26e (patch)
treee7aeb97f92b782a9284689abe3c44de14eaa08a2
downloadaur-7bc03e7922fd6a8be2204f6d2ca94a82dafac26e.tar.gz
0.5.2-1: Initial package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b931d8c6830d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-duppy
+ pkgdesc = OCaml asynchronous scheduler and monad for server-oriented programming
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-duppy
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-pcre
+ options = !strip
+ source = https://github.com/savonet/ocaml-duppy/releases/download/0.5.2/ocaml-duppy-0.5.2.tar.gz
+ md5sums = 61e211489bb7c3106b63db7ac03e3f7c
+
+pkgname = ocaml-duppy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef78fa62118f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-duppy
+pkgver=0.5.2
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml asynchronous scheduler and monad for server-oriented programming")
+url="https://github.com/savonet/ocaml-duppy"
+depends=('ocaml' 'ocaml-pcre')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-duppy/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('61e211489bb7c3106b63db7ac03e3f7c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}