summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bailey2019-09-06 04:56:39 -0400
committerEric Bailey2019-09-06 04:56:39 -0400
commit33d25a244b14378af832e6c657adeaf9a07d53de (patch)
tree4f79276bd9b7c6bab6af6da2052038b1adc2c42f
parent3b8cbfcce3fb383010ffa0a51fad1d74332af9ae (diff)
downloadaur-33d25a244b14378af832e6c657adeaf9a07d53de.tar.gz
1.3.1-5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 28 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d92f5e2a048..6b5f6ba07d62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-# Generated by mksrcinfo v8
-# Sun Feb 4 00:11:49 UTC 2018
pkgbase = ocaml-easy-format
- pkgdesc = Data pretty printing made easy
+ pkgdesc = Pretty-printing library for OCaml
pkgver = 1.3.1
- pkgrel = 3
- url = https://github.com/mjambon/easy-format
- arch = i686
+ pkgrel = 5
+ url = https://github.com/ocaml-community/easy-format
arch = x86_64
- arch = armv7h
license = BSD
- makedepends = ocaml-findlib
makedepends = dune
+ depends = glibc
options = !strip
options = staticlibs
- source = https://github.com/mjambon/easy-format/archive/v1.3.1.tar.gz
+ source = ocaml-easy-format-1.3.1.tar.gz::https://github.com/ocaml-community/easy-format/archive/v1.3.1.tar.gz
sha256sums = 489d55ea5de171cea2d7e2114bcd5cebd1fcbf89f839fbf3757769507502e1f0
pkgname = ocaml-easy-format
diff --git a/PKGBUILD b/PKGBUILD
index a9cad24c7666..990dd002a487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
+# Author: Bruno Pagani <archange@archlinux.org>
# Maintainer: nerflad <nerflad@gmail.com>
-pkgname=ocaml-easy-format
-_oname=easy-format
+_pkgname=easy-format
+pkgname=ocaml-${_pkgname}
pkgver=1.3.1
-pkgrel=3
-pkgdesc="Data pretty printing made easy"
-url="https://github.com/mjambon/easy-format"
-arch=('i686' 'x86_64' 'armv7h')
-options=('!strip' 'staticlibs')
+pkgrel=5
+pkgdesc="Pretty-printing library for OCaml"
+arch=('x86_64')
+url="https://github.com/ocaml-community/${_pkgname}"
license=('BSD')
-makedepends=('ocaml-findlib' 'dune')
-source=("https://github.com/mjambon/${_oname}/archive/v${pkgver}.tar.gz")
+options=('!strip' 'staticlibs')
+depends=('glibc')
+makedepends=('dune')
+source=(${pkgname}-${pkgver}.tar.gz::"${url}/archive/v${pkgver}.tar.gz")
sha256sums=('489d55ea5de171cea2d7e2114bcd5cebd1fcbf89f839fbf3757769507502e1f0')
+
build() {
- cd ${srcdir}/${_oname}-${pkgver}
- make all
- sed -i '/doc:\s\[/,$d' _build/default/easy-format.install
+ cd ${_pkgname}-${pkgver}
+ make all
+}
+
+check() {
+ cd ${_pkgname}-${pkgver}
+ make test
}
package() {
- cd ${srcdir}/${_oname}-${pkgver}
- export OCAMLFIND_DESTDIR="${pkgdir}/$(ocamlfind printconf destdir)"
- install -dm755 "$OCAMLFIND_DESTDIR"
- jbuilder install
+ cd ${_pkgname}-${pkgver}
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlfind printconf destdir)"
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
+ rm -r "${pkgdir}"/usr/doc
}