summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2016-02-07 13:22:35 +0100
committerJ5lx2016-02-07 13:22:35 +0100
commita5d7d49252e083fa6e79d7fcf9daadfe90d00444 (patch)
treebe064d4e852abd684cee9c2504d82b0109358811
downloadaur-a5d7d49252e083fa6e79d7fcf9daadfe90d00444.tar.gz
1.13.0-1: Initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..710cdc4a66ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 12:22:19 UTC 2016
+pkgbase = ocaml-efl
+ pkgdesc = An OCaml interface to the Enlightenment Foundation Libraries (EFL) and Elementary
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = https://forge.ocamlcore.org/projects/ocaml-efl/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = efl
+ depends = elementary
+ options = !strip
+ source = https://forge.ocamlcore.org/frs/download.php/1499/ocaml-efl-1.13.0.tar.gz
+ md5sums = b7e5fc04f8fa644b30032da471d557e6
+
+pkgname = ocaml-efl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46902a96b453
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-efl
+pkgver=1.13.0
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc="An OCaml interface to the Enlightenment Foundation Libraries (EFL) and Elementary"
+url="https://forge.ocamlcore.org/projects/ocaml-efl/"
+depends=('ocaml' 'efl' 'elementary')
+makedepends=('ocaml-findlib')
+source=("https://forge.ocamlcore.org/frs/download.php/1499/ocaml-efl-1.13.0.tar.gz")
+options=('!strip')
+md5sums=('b7e5fc04f8fa644b30032da471d557e6')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install OCAMLFIND_DESTDIR="${OCAMLFIND_DESTDIR}"
+}