summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-11-16 02:29:28 +0800
committerYen Chi Hsuan2016-11-16 02:29:28 +0800
commit3551792ddc251694040edfc5c154c726d86f4bf0 (patch)
tree2ee9cf5837a8e2adf0c7fdc709a800453311251c
parent6cd49ce998a496d4593826eb0b954dbd4990469f (diff)
downloadaur-3551792ddc251694040edfc5c154c726d86f4bf0.tar.gz
Bump to 1.7.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 22 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b504b0dc3fc1..b4521ba27113 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Jan 9 11:34:43 UTC 2016
+# Tue Nov 15 18:29:20 UTC 2016
pkgbase = ocaml-extlib
pkgdesc = Extends the OCaml standard library
- pkgver = 1.7.0
- pkgrel = 2
- url = http://code.google.com/p/ocaml-extlib/
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = https://github.com/ygrek/ocaml-extlib
arch = i686
arch = x86_64
license = LGPL
makedepends = ocaml-findlib
- makedepends = camlp4
makedepends = cppo
depends = ocaml
options = staticlibs
- options = !makeflags
- source = https://github.com/ygrek/ocaml-extlib/archive/1.7.0.tar.gz
- md5sums = b50b02d9e40d35cc20c82d9c881a1bf6
+ source = ocaml-extlib-1.7.1.tar.gz::https://github.com/ygrek/ocaml-extlib/archive/1.7.1.tar.gz
+ sha256sums = 872a492be08bb99ddac7512ec190625718359458b79cfc710f40d5a967f628eb
pkgname = ocaml-extlib
diff --git a/PKGBUILD b/PKGBUILD
index 4c9070e57a4d..94d7a80bfd6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,36 @@
-# Maintainer: lesebas < sebdeligny at gmail dot com>
+# Maintainer: Yen Chi Hsuan < yan12125 at gmail dot com >
+# Contributor: lesebas < sebdeligny at gmail dot com>
pkgname=ocaml-extlib
-pkgver=1.7.0
-pkgrel=2
+pkgver=1.7.1
+pkgrel=1
pkgdesc="Extends the OCaml standard library"
arch=('i686' 'x86_64')
-url="http://code.google.com/p/ocaml-extlib/"
+url="https://github.com/ygrek/ocaml-extlib"
license=('LGPL')
depends=('ocaml')
-makedepends=('ocaml-findlib' 'camlp4' 'cppo')
-source=(https://github.com/ygrek/ocaml-extlib/archive/${pkgver}.tar.gz)
-options=('staticlibs' '!makeflags')
+makedepends=('ocaml-findlib' 'cppo')
+source=("$pkgname-$pkgver.tar.gz"::"https://github.com/ygrek/ocaml-extlib/archive/${pkgver}.tar.gz")
+options=('staticlibs')
+sha256sums=('872a492be08bb99ddac7512ec190625718359458b79cfc710f40d5a967f628eb')
build() {
- cd ${srcdir}/ocaml-extlib-${pkgver}/src
+ cd ocaml-extlib-${pkgver}
- make all
- make opt
-
- sed -i 's/cp odoc_style.css/#cp odoc_style.css/g' Makefile
- sed -i 's/ocamldoc -sort -html/ocamldoc -sort -keep-code -html -colorize-code/g' Makefile
+ make build
make doc
-
- # Install additional files
- sed -i 's/ocamlfind install extlib META/ocamlfind install extlib META *.cmo *.cmx *.ml/g' Makefile
}
package () {
_DOCDIR="${pkgdir}/usr/share/doc/ocaml-extlib"
- cd ${srcdir}/ocaml-extlib-${pkgver}
+ cd ocaml-extlib-${pkgver}
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}"
+ install -Ddm755 "${OCAMLFIND_DESTDIR}"
make install
-
+
# Install doc
- mkdir -p $_DOCDIR
- cp -r src/doc/* $_DOCDIR/
+ install -Ddm755 "$_DOCDIR"
+ cp -dr --no-preserve=ownership src/doc/* "$_DOCDIR/"
}
-md5sums=('b50b02d9e40d35cc20c82d9c881a1bf6')