summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornull2015-08-25 17:33:04 -0400
committernull2015-08-25 17:33:04 -0400
commitddac6d8f33bf75479ccc742bd4f06b411e3cbcdf (patch)
tree7441c36f7e57d8dba866804bd702f58359831c1d
downloadaur-ddac6d8f33bf75479ccc742bd4f06b411e3cbcdf.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16eecaf50f4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Mon May 11 08:08:08 UTC 2015
+pkgbase = ocaml-extlib
+ pkgdesc = Extends the OCaml standard library
+ pkgver = 1.6.1
+ pkgrel = 2
+ url = http://code.google.com/p/ocaml-extlib/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ocaml-findlib
+ makedepends = camlp4
+ depends = ocaml
+ options = staticlibs
+ source = http://ocaml-extlib.googlecode.com/files/extlib-1.6.1.tar.gz
+ md5sums = 5643237a6410dc915347956cff97df86
+
+pkgname = ocaml-extlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83d06a3d2627
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Patryk Kowalczyk < patryk at kowalczyk dot ws>
+
+pkgname=ocaml-extlib
+pkgver=1.6.1
+pkgrel=2
+pkgdesc="Extends the OCaml standard library"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/ocaml-extlib/"
+license=('LGPL')
+depends=('ocaml')
+makedepends=('ocaml-findlib' 'camlp4')
+source=(http://ocaml-extlib.googlecode.com/files/extlib-${pkgver}.tar.gz)
+options=('staticlibs')
+
+build() {
+ cd ${srcdir}/extlib-${pkgver}
+
+ make all
+ make opt
+
+ sed -i 's/cp odoc_style.css/#cp odoc_style.css/g' Makefile
+ sed -i 's/ocamldoc -sort -html/ocamldoc -sort -keep-code -html -colorize-code/g' Makefile
+ make doc
+
+ # Install additional files
+ sed -i 's/ocamlfind install extlib META/ocamlfind install extlib META *.cmo *.cmx *.ml/g' Makefile
+}
+
+package () {
+ _DOCDIR="${pkgdir}/usr/share/doc/ocaml-extlib"
+
+ cd ${srcdir}/extlib-${pkgver}
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+ make install
+
+ # Install doc
+ mkdir -p $_DOCDIR
+ cp -r doc/* $_DOCDIR/
+}
+md5sums=('5643237a6410dc915347956cff97df86')