summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Letan2024-01-21 15:29:13 +0100
committerThomas Letan2024-01-21 15:29:13 +0100
commitfae9001d9984aa647d488f278652ec8b26774000 (patch)
tree31edec67b9b0a0cb98384e674ceaf3175ad3af7f
downloadaur-fae9001d9984aa647d488f278652ec8b26774000.tar.gz
ocaml-ezjsonm.1.3.0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96e64154266d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ocaml-ezjsonm
+ pkgdesc = Hexadecimal converter
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/mirage/ocaml-ezjsonm
+ arch = x86_64
+ license = custom:ISC
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-hex
+ depends = ocaml-uutf
+ depends = ocaml-sexplib0
+ depends = ocaml-jsonm
+ options = !strip
+ source = ocaml-ezjsonm-1.3.0.tbz::https://github.com/mirage/ezjsonm/releases/download/v1.3.0/ezjsonm-1.3.0.tbz
+ sha512sums = b731036384115603af9187464695418d27b7cf6f763c8dbc0812db62a7657cac1b6019d3b205b1c95ae81b7dab0bd4037390d977ee8c122bef29a9ddef771e18
+
+pkgname = ocaml-ezjsonm
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..297aeb817c8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+ocaml-ezjsonm-*.pkg.tar.zst
+ocaml-ezjsonm-*.tbz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bea8bbdaab39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Thomas Letan <lthms@soap.coffee>
+
+pkgname=ocaml-ezjsonm
+pkgver=1.3.0
+pkgrel=1
+license=('custom:ISC')
+arch=('x86_64')
+pkgdesc="Hexadecimal converter"
+url="https://github.com/mirage/ocaml-ezjsonm"
+depends=(
+ 'ocaml'
+ 'ocaml-hex'
+ 'ocaml-uutf'
+ 'ocaml-sexplib0'
+ 'ocaml-jsonm'
+)
+makedepends=('dune')
+source=(
+ "$pkgname-$pkgver.tbz::https://github.com/mirage/ezjsonm/releases/download/v$pkgver/ezjsonm-$pkgver.tbz"
+)
+options=('!strip')
+sha512sums=(
+ "b731036384115603af9187464695418d27b7cf6f763c8dbc0812db62a7657cac1b6019d3b205b1c95ae81b7dab0bd4037390d977ee8c122bef29a9ddef771e18"
+)
+
+build() {
+ cd "${srcdir}/ezjsonm-${pkgver}"
+ # The "-p" flag is necessary for release builds, see the Dune manpage. Dune will complain if you forget some packages.
+ dune build -p ezjsonm
+}
+
+package() {
+ cd "${srcdir}/ezjsonm-${pkgver}"
+ DESTDIR="${pkgdir}" dune install ezjsonm --prefix "/usr" --libdir "/usr/lib/ocaml" --docdir "/usr/share/doc"
+}