summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-15 15:52:57 +0200
committerGoliathLabs2020-05-15 15:52:57 +0200
commit16e779979c8dccb4bf93a08321b840f8f2014db4 (patch)
tree447bd86a498e8eaa10c738f27d6f0cddfe1180de
parente27e2da09e288f6385bb5029ef5f54f265440061 (diff)
downloadaur-16e779979c8dccb4bf93a08321b840f8f2014db4.tar.gz
Updated: 0.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d39c8295b42..57f5208940ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-fdkaac
pkgdesc = OCaml bingind for the fdk-aac library
- pkgver = 0.3.1
+ pkgver = 0.3.2
pkgrel = 1
url = https://github.com/savonet/ocaml-fdkaac
arch = i686
@@ -8,10 +8,10 @@ pkgbase = ocaml-fdkaac
license = GPL
makedepends = ocaml-findlib
depends = ocaml
- depends = libfdk-aac<=0.1.6
+ depends = libfdk-aac
options = !strip
- source = https://github.com/savonet/ocaml-fdkaac/releases/download/0.3.1/ocaml-fdkaac-0.3.1.tar.gz
- md5sums = 8f97fbb8748732eb4a3b6e830cee61dc
+ source = https://github.com/savonet/ocaml-fdkaac/archive/0.3.2.tar.gz
+ sha256sums = 0de28749e1435839ead013c385c6b963b88b57770e362e067139c2fd67a52e5f
pkgname = ocaml-fdkaac
diff --git a/PKGBUILD b/PKGBUILD
index 13073bf3482b..2c983429560b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-fdkaac
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=1
pkgdesc="OCaml bingind for the fdk-aac library"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-fdkaac"
license=('GPL')
-depends=('ocaml' 'libfdk-aac<=0.1.6')
+depends=('ocaml' 'libfdk-aac')
makedepends=('ocaml-findlib')
options=('!strip')
-source=("https://github.com/savonet/ocaml-fdkaac/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('8f97fbb8748732eb4a3b6e830cee61dc')
+source=("https://github.com/savonet/ocaml-fdkaac/archive/${pkgver}.tar.gz")
+sha256sums=('0de28749e1435839ead013c385c6b963b88b57770e362e067139c2fd67a52e5f')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure
- make
+ dune build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
}