summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 22:03:36 +0100
committerGianluca Boiano2021-02-28 22:03:36 +0100
commit64ad69b662baf8affa22453fd5dae562ccc2a3ea (patch)
tree3f2ceae7c95adb966fc8031bc636d13fb404e1fd
parentc256d6082af75ff410085ee46e7e6ba625ff3755 (diff)
downloadaur-64ad69b662baf8affa22453fd5dae562ccc2a3ea.tar.gz
ocaml-fdkaac: fix dune compilation
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b03af0509a..97f9e51d4016 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = ocaml-fdkaac
pkgdesc = OCaml bingind for the fdk-aac library
pkgver = 0.3.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/savonet/ocaml-fdkaac
arch = i686
arch = x86_64
license = GPL
makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml
depends = libfdk-aac
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 8ff632ab2738..3a52aec2c173 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=ocaml-fdkaac
pkgver=0.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="OCaml bingind for the fdk-aac library"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-fdkaac"
license=('GPL')
depends=('ocaml' 'libfdk-aac')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip')
source=("https://github.com/savonet/ocaml-fdkaac/archive/${pkgver}.tar.gz")
@@ -23,8 +23,10 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- dune install --prefix "${pkgdir}/usr" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
sha256sums=('0de28749e1435839ead013c385c6b963b88b57770e362e067139c2fd67a52e5f') \ No newline at end of file