summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302020-05-01 16:09:52 +0200
committerM0Rf302020-05-01 16:09:52 +0200
commitc1201e4d28051ae7960890f8cd653d2e941903b0 (patch)
tree3418fb4037da9ad351d8842f93dad6687e405436
parente0c05153408b78ba1bb2cfe3b4dccdad7c992446 (diff)
downloadaur-c1201e4d28051ae7960890f8cd653d2e941903b0.tar.gz
ocaml-fdkaac-git: fix build stage
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 285c86e03b0a..98db7ba00f48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = ocaml-fdkaac-git
pkgdesc = OCaml binding for the fdk-aac library
- pkgver = r74.872fa6b
+ pkgver = r80.cc4245a
pkgrel = 1
url = https://github.com/savonet/ocaml-fdkaac
arch = i686
arch = x86_64
license = GPL
- makedepends = ocaml-findlib
+ makedepends = dune
+ makedepends = dune-configurator
depends = ocaml
depends = libfdk-aac
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index e6a9718281c5..db212c48cf4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: robertfoster
pkgname=ocaml-fdkaac-git
-pkgver=r74.872fa6b
+pkgver=r80.cc4245a
pkgrel=1
pkgdesc="OCaml binding for the fdk-aac library"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-fdkaac"
license=('GPL')
depends=('ocaml' 'libfdk-aac')
-makedepends=('ocaml-findlib')
+makedepends=('dune' 'dune-configurator')
options=('!strip' '!makeflags')
source=("${pkgname}::git+https://github.com/savonet/ocaml-fdkaac.git")
@@ -18,17 +18,13 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}"
- ./bootstrap
- ./configure
- make
+ dune build
}
package() {
cd "${srcdir}/${pkgname}"
-
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
}
pkgver() {