summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 19:03:15 +0200
committerJ5lx2015-10-10 19:03:15 +0200
commitcabd50232bc60d569aaeb5a55f50f0806cdd96b2 (patch)
tree6e1b0198d090cae889ab407922198a1ea30123fd
downloadaur-cabd50232bc60d569aaeb5a55f50f0806cdd96b2.tar.gz
0.1.1-1: Initial package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d88ecb83a3d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-ffmpeg
+ pkgdesc = OCaml bindings to the FFmpeg library
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-ffmpeg
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ffmpeg
+ options = !strip
+ source = https://github.com/savonet/ocaml-ffmpeg/releases/download/0.1.1/ocaml-ffmpeg-0.1.1.tar.gz
+ md5sums = 7c0c7198c877d72668a14c6d4400ba8c
+
+pkgname = ocaml-ffmpeg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26c02b862188
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ffmpeg
+pkgver=0.1.1
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bindings to the FFmpeg library")
+url="https://github.com/savonet/ocaml-ffmpeg"
+depends=('ocaml' 'ffmpeg')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-ffmpeg/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('7c0c7198c877d72668a14c6d4400ba8c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}