summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-03 17:56:39 +0200
committerJ5lx2015-07-03 17:56:39 +0200
commit195d687df04fcf890f5d39e947c64d7941cd477e (patch)
tree21edefa7866b38d06166b841cdbaddb144f34b51
downloadaur-195d687df04fcf890f5d39e947c64d7941cd477e.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8966de8af7e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ocaml-fieldslib
+ pkgdesc = OCaml record fields as first class values
+ pkgver = 109.20.03
+ pkgrel = 1
+ url = https://github.com/janestreet/fieldslib
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = camlp4
+ depends = ocaml-type_conv
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/109.20.00/individual/fieldslib-109.20.03.tar.gz
+ md5sums = 9e18d16c61a4e4a38e8e33b6f6f00ddf
+
+pkgname = ocaml-fieldslib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14df5deeb32a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-fieldslib
+pkgver=109.20.03
+pkgrel=1
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="OCaml record fields as first class values "
+url="https://github.com/janestreet/fieldslib"
+depends=('ocaml' 'camlp4' 'ocaml-type_conv')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+").00/individual/${pkgname#ocaml-}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('9e18d16c61a4e4a38e8e33b6f6f00ddf')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "$OCAMLFIND_DESTDIR"
+ DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" \
+ make install
+}