summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2016-02-06 01:50:29 +0100
committerJ5lx2016-02-06 01:50:29 +0100
commit72828ba48bc0c0e3e34009307c018e1cf54bf6bf (patch)
treea57996c49e7bca118e8146d2c47e4d08d1af6dfa
parent4b7aada0b2c2945a3b09272a922caa4f3e9a1fe4 (diff)
downloadaur-72828ba48bc0c0e3e34009307c018e1cf54bf6bf.tar.gz
113.24.00-1: New version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0746966207ae..2a6664f625a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 00:49:36 UTC 2016
pkgbase = ocaml-fieldslib
pkgdesc = OCaml record fields as first class values
- pkgver = 113.00.00
+ pkgver = 113.24.00
pkgrel = 1
url = https://github.com/janestreet/fieldslib
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = opam
depends = ocaml
depends = camlp4
depends = ocaml-type_conv
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.00/files/fieldslib-113.00.00.tar.gz
- md5sums = 1d6c41507d25bcfdd24ce4e97efea404
+ source = https://ocaml.janestreet.com/ocaml-core/113.24/files/fieldslib-113.24.00.tar.gz
+ md5sums = 3afa341134a5e4e4b583f6c617fa4e72
pkgname = ocaml-fieldslib
diff --git a/PKGBUILD b/PKGBUILD
index f95c1bdf5f7b..2a753719cb5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-fieldslib
-pkgver=113.00.00
+pkgver=113.24.00
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="OCaml record fields as first class values "
url="https://github.com/janestreet/fieldslib"
depends=('ocaml' 'camlp4' 'ocaml-type_conv')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
options=('!strip')
-md5sums=('1d6c41507d25bcfdd24ce4e97efea404')
+md5sums=('3afa341134a5e4e4b583f6c617fa4e72')
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
@@ -23,9 +23,5 @@ build() {
package() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
- OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "$OCAMLFIND_DESTDIR"
- DESTDIR="${pkgdir}" \
- OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" \
- make install
+ make install PREFIX="${pkgdir}/usr"
}