summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2021-02-02 19:11:06 +0100
committerSeverin Glöckner2021-02-02 19:11:06 +0100
commite5423ea2e6ede9911cb87f43d01f254c2ae0c22e (patch)
tree9acd7cd1a3501a7ee8cef04465d63aaad14702c6
parentc6bff3de3a35cb7f654ee589cf4da91b54b8f626 (diff)
downloadaur-e5423ea2e6ede9911cb87f43d01f254c2ae0c22e.tar.gz
v5.1.1#
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 300588a87ee4..7bd8f242e574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = ocaml-graphics
pkgdesc = Graphics library from OCaml
- pkgver = 5.1.0
+ pkgver = 5.1.1
pkgrel = 1
url = https://github.com/ocaml/graphics
arch = x86_64
license = LGPL2.1
makedepends = dune
depends = ocaml>=4.0.9
- source = https://github.com/ocaml/graphics/archive/5.1.0.tar.gz
- sha256sums = 132e0597f42b11ef5d9b0a523fee2edab7c55efd9c3f198d5574349b4595fafb
+ source = https://github.com/ocaml/graphics/archive/5.1.1.tar.gz
+ sha256sums = dbef15667cdab65672c60739d5e51ff4341b9595fbc6e39003368637b5915240
pkgname = ocaml-graphics
diff --git a/PKGBUILD b/PKGBUILD
index 99c0de24a3c8..43271c0fe25f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# This package contains it.
pkgname=ocaml-graphics
-pkgver=5.1.0
+pkgver=5.1.1
pkgrel=1
pkgdesc="Graphics library from OCaml"
arch=('x86_64')
@@ -14,7 +14,7 @@ license=('LGPL2.1')
depends=('ocaml>=4.0.9')
makedepends=('dune')
source=("https://github.com/ocaml/graphics/archive/${pkgver}.tar.gz")
-sha256sums=('132e0597f42b11ef5d9b0a523fee2edab7c55efd9c3f198d5574349b4595fafb')
+sha256sums=('dbef15667cdab65672c60739d5e51ff4341b9595fbc6e39003368637b5915240')
build() {
cd "${srcdir}/graphics-${pkgver}"
@@ -25,18 +25,17 @@ build() {
package() {
cd "${srcdir}/graphics-${pkgver}"
- DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
- install -dm755 "${pkgdir}/usr/share/"
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
# there's nothing useful inside
rm -r "${pkgdir}/usr/doc/"
+ # license has an addition to LGPL2.1
install -Dm644 "$srcdir"/graphics-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
# unfortunately, the files won't be found in the subfolder. Linking them
cd "${pkgdir}/usr/lib/ocaml/"
-
for file in graphics/*graphics*
do
ln -s graphics/$(basename "$file") $(basename "$file")